Ford Ranger idling problem

Discussion in 'Mechanic and Repair' started by Vikings, Jun 8, 2007.

  1. Vikings

    Vikings LawnSite Bronze Member
    from canada
    Posts: 1,667

    My ford ranger '96 6 cycl. is reving up then settles down over and over.

    If I'm sitting there with my foot on the brake it will click then rev about 3000 rpms then settle back down, then do it again, about every 10-15 seconds.

    There is also a background with this problem:

    This truck, ever since I bought it revs high at start up.. at least high in my opinion. I have to wait about 10 seconds till it revs down to where I can put it in gear. I'm putting my truck in gear at 15k rpms and I think the normal 'high' rev is about 10,000.

    Right now it's idling at about 6-7,000 rpms, clicking, revs up 3,000 rpms then back down.

    Now I had this problem before and they ended up fixing it but charged me lot and when I got the truck back, it still reved high at start up but the clicking was gone. I think they did an Injector flush but also some other things.. they basically sold me the farm.

    Unfortunately my mechanic report is in the hands of my accountant as that happened in Dec.
     
  2. LindblomRJ

    LindblomRJ LawnSite Silver Member
    Posts: 2,570

    If its revving to 15,000 RPMs and idle speed is 6,000 to 7,000 RPMs I am surprised you have an engine left.

    Which 6 cylinder? The 3.0 or the 4.0? Might be a computer issue. It should be equipped with a OBD-II that a compatible scanner should plug into and spew codes see if there is a code. If it is equipped with a OBD-II read most parts stores have one you can borrow or rent in hopes of selling you the correct part. Try that route.

    As far as specifics I really do not have any idea.
     
  3. wkumatt

    wkumatt LawnSite Member
    Posts: 16

    Not sure how a 96 is wired but if it is equipped with a mass air flow sensor a leak in that system will cause the computer to surge seeking the right voltage range from that sensor. Had a comparable problem on a Mits Lancer.
     
  4. Vikings

    Vikings LawnSite Bronze Member
    from canada
    Posts: 1,667

    Sorry about that... too many zeros, wishful thinking like my money.:laugh:

    It does have a mass air flow and the last few times I took, it in they suggested servicing it. I turned them down because.. well you know how mechanics are.. upsell upsell...

    It's a 4.0 litre.

    After some fooling around I found that it is related to the air conditioning compressor. It clicks (the clicking I hear) then the centre of the compressor starts turning, the engine revs, it stops turning and the engine revs down.

    The Air never even worked on this truck but For some reason it get engaged when I turn the fan on. It's been raining a lot and I've been keeping cool defrost on to keep the window clear.

    I turned the fan switch to off and now I have no 'erratic idling' but it comes right back if I turn the fan on.. heat or air.

    I bought the manual and it shows how to replace the compressor and recharge the refrigerant. I wonder if that would give me air conditioning and fix my prob.
     
  5. wkumatt

    wkumatt LawnSite Member
    Posts: 16

    I can tell you that any vehicle set to defrost will activate the AC compressor, they are wired this way so that the compressor will be "exercised" over the winter months.
     
  6. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,023

    If the air conditioning is not cooling just un-plug the compressor, This will keep it from coming on when you turn the defrosters on (high idle RPM). When you replace the compressor plug the new one back up.

    But, If the compressor is cycling quickly as you stated thats a sign of low refrigerant. The compressor could be just fine and the system just have a leak which lowered the refrigerant level. There is a low pressure switch that tells the compressor to kick off so not to damage the compressor should the system get low.
     
  7. TGM

    TGM LawnSite Senior Member
    Posts: 931

    ok, so you're saying that the rpms are going up and down 300 rpms every 10 seconds or so? then yes, it's the compressor.

    1500rpms at cold startup is about right, maybe a tad high..maybe not for a ranger...it's just adding fuel compensating for cold cylinder temps until the engine warms up.
     
  8. Vikings

    Vikings LawnSite Bronze Member
    from canada
    Posts: 1,667



    That's what I'll do.. why didn't I think of that?

    Thanks Guys.
     
  9. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,023

    Check the edit in my post above ^^^^^^^^^^
     
  10. Vikings

    Vikings LawnSite Bronze Member
    from canada
    Posts: 1,667

    I understand that for when it's cold, we get a lot of that here in Canada. But we might do 18 lawns in a day and up to 50 drive ways in the winter. It zooms up at the start no matter what. I just checked, it zooms up to 1800 rpms.

    This is trivial but I have to wait ten secs EVERY TIME! and people are on the clock.:laugh:
     

Share This Page