Fs-90

Discussion in 'Mechanic and Repair' started by mikeylikesit5805, Jul 23, 2008.

  1. mikeylikesit5805

    mikeylikesit5805 LawnSite Senior Member
    from Kent OH
    Posts: 336

    Alright ive got a problem. I have an fs-90 about 2 months old. Since the day i got it its had problems. First the fuel pickup line, no big deal. And now i have a h*ll of a time starting it. It takes a good 20 pulls to even get started and once it is started it blows smoke, and runs bad. It takes about 5 minutes for it to run good. And once it warms up it runs great. no problems. so i dont know what the problem is. Any one have any ideas.

    Thanks

    -Mike
     
  2. KGR landscapeing

    KGR landscapeing LawnSite Bronze Member
    Posts: 1,544

    did u buy it from a dealer? take it back i would also suggest changing ur fuel mix r u running stihl mix? do the reccomend the 89 octane for those too? check the spark arrestor on the muffler 2
     
  3. Back2Back

    Back2Back LawnSite Member
    from Ok
    Posts: 13

    I just bought one the other day and it ran good at first and now i cant get it started. I believe the fuel line is messed up like yours was. How did you fix it?
     
  4. mikeylikesit5805

    mikeylikesit5805 LawnSite Senior Member
    from Kent OH
    Posts: 336

    I took it back to the dealer. I guess all they had to do was push it back up in a little farther.
     
  5. freshprince94

    freshprince94 LawnSite Bronze Member
    Posts: 1,449

    Take it to a dealer...
     
  6. STIHL GUY

    STIHL GUY LawnSite Fanatic
    from CT
    Posts: 5,225

    the dealer will fix it for you
     
  7. JLAWNCARE

    JLAWNCARE LawnSite Member
    Posts: 42

    after the first 20 hrs stihl recomends valve adjustment i had i do the same thing .and from the valves need adjustin carbons build up in youre muffler filter this is all under war and thy should beable to do it while you wait
     
  8. readycutlawncare

    readycutlawncare LawnSite Member
    Posts: 31

    i am having problems with my fs 90 too also my km 90, they both are idling up and down and loosing power, and when you let off the throttle they just shut off. I have been backl and forth to my dealer for the last two weeks and they can't seem to fix the problem. they have said the have repalced everything, lines, carburator, spark plugs, air filter, gas filter. and still can't figure out the problem. so they just gave me two loaners while they try to come up with something to try to fix them.
     
  9. mikeylikesit5805

    mikeylikesit5805 LawnSite Senior Member
    from Kent OH
    Posts: 336

    Alright, Great News and Bad News. I normally go in and pay while my worker fills up the gas cans well today i payed with my credit card and just watched him fill up the mix. I noticed that he only used 2.0 gallons of gas with the 2.5 gallon mix!!! I questioned him and he said that he had been doing this for a long time. I dont think it hurt anything, just ran a little rich, but wow. So i put another half gallon in, emptied out all the old gas and run the new stuff through. Seemed to Help alot.
     
  10. PLS-Tx

    PLS-Tx LawnSite Silver Member
    from Texas
    Posts: 2,385

    I always mix my own gas.
     

Share This Page