1. Missed the live Ask the Expert event?
    Not to worry. Check out the archived thread of the Q&A with Ken Hutcheson, President of U.S. Lawns, and the LawnSite community in the Franchising forum .

    Dismiss Notice

Fuel filter HELP #2!!!!! Please!

Discussion in 'Trucks and Trailers' started by UrbanGreen, Mar 9, 2008.

  1. UrbanGreen

    UrbanGreen LawnSite Member
    Posts: 162

    After the fuel filter change and priming the hell out of my 06' LBZ duramax it finally cranked back up. However it is idleing really funny and the message board on the dash will not come back on......what do I do now?
  2. IA_James

    IA_James LawnSite Silver Member
    from Iowa
    Posts: 2,593

    Let it run for a while, should come out of it.
  3. UrbanGreen

    UrbanGreen LawnSite Member
    Posts: 162

    Yea I let it run for about 5 min. and it started running normal again but then went back to the weird idleing. Any ideas on the message board problem?
  4. Lawnworks

    Lawnworks LawnSite Fanatic
    from usa
    Posts: 5,407

    Did you use a GM fuel filter? I didn't use one last time, and sometimes I have to prime it to start.
  5. UrbanGreen

    UrbanGreen LawnSite Member
    Posts: 162

    Yep GM fuel filter. I have always used GM but I have never had these problems.
  6. TXNSLighting

    TXNSLighting LawnSite Fanatic
    from DFW, TX
    Posts: 6,462

    man i really think there maybe something else that you might of revealed by changing the filter. you may want to tak it to the dealer. some 06 lbzs had fueling issues. and other problems.

Share This Page