Got a new web site

Discussion in 'Digital Marketing' started by nac, Sep 24, 2004.

  1. nac

    nac LawnSite Member
    Posts: 126

    :blob3: Just got a new website up and running for my company. Tell me what you guys think is there anything wrong or any suggestions. Thanks :blob3:
     
  2. i_plant_art

    i_plant_art LawnSite Senior Member
    Posts: 558

    hey man site looks good but check out the servies page inder the JD backhoe pick you have typed "We have multiple piecesof equipment " just need to add a space b/t pieces & of...........also on the consumer tips page.... maybe make the bullet points text bigger to stand out more.... just a suggestion... all the blue text also kinda stained my eyes some.. but it could just be me.... other than those small thigs i think your new site looks tight and VERY professional. im impressed.
     
  3. mdvaden

    mdvaden LawnSite Bronze Member
    Posts: 1,937

    HOME PAGE

    1. Consumers has a possessive apostrophe and it is not possessive.

    2. Surrounding is spelled incorrectly.

    3. Commercial is missing an m

    4. Retaining is missing "i" and "n"

    I did not get to the deeper part of the site.

    Hope that helps.
     
  4. nac

    nac LawnSite Member
    Posts: 126

    Thanks for the help.
     
  5. Ferngolf

    Ferngolf LawnSite Member
    from NJ
    Posts: 19

    I just went through the site and noticed all the errors, then came back to the thread and saw the posts. It is too good of a site to have all the grammer problems. Go through it real close and correct. Let us know when you have fixed and we will run through it again.
    Do you sub everything out? There does not seem to be many companies who do all of the different things that you do so well under one roof.
    Nice stuff.
     
  6. nac

    nac LawnSite Member
    Posts: 126

    Yes I am slowly going over the site to fix errors. Most of the work is done in house electrical and plumbing and some of the framing is subbed out.
    Thanks.
     
  7. nac

    nac LawnSite Member
    Posts: 126

    Just figured out how to copy my web site and paste it to Microsoft Word and do spell check. I think I got everything, if you see any other mistakes please point them out to me.
    Thank you.
     
  8. Team Gopher

    Team Gopher LawnSite Platinum Member
    from -
    Posts: 4,041

    Hi Nac,

    Everything looked good to me! Nice work!
     
  9. nac

    nac LawnSite Member
    Posts: 126

    Thank you very much.
     
  10. mdvaden

    mdvaden LawnSite Bronze Member
    Posts: 1,937

    Looks better since my last visit.

    I noticed one misspell on a caption on my site, but otherwise I'm doing okay. I've got huge volumes of text and know a few errors are here and there.

    The home page is the most critical in my view.

    Hope your site does what you need.
     

Share This Page