grasshopper 618 gemini eaton hydro

Discussion in 'General Industry Discussions' started by joedan, Aug 20, 2010.

  1. joedan

    joedan LawnSite Member
    Posts: 4

    I read on a google thread of a person with the same lack of power on his grasshopper. Mine is also a 618, 1998 model. In his thread he mentioned that he was told he could replace his hydro motors for 650.00 eash but he preferred to rebuild himself. I just want to know where i can get these 2 hydro motors for 650.00 each. My transaxles are fine and i do not want to spend 1699.00 for each side from a dealer plus labor. Help help tahnks dan
     
  2. ECO Landscaping

    ECO Landscaping LawnSite Member
    Posts: 126

    Try looking at JThomas.com. I thing they sell for $800 each side.
    Posted via Mobile Device
     
  3. Mowingman

    Mowingman LawnSite Platinum Member
    from Texas
    Posts: 4,656

    Have you tried changing the hydro filters and the hydro oil. It might perform better. Unless you have a lot of hours on that machine, you should not be having hydro. problems. By lots of hours, I mean in the neighborhood of 2000 + hours.
     
  4. joedan

    joedan LawnSite Member
    Posts: 4

    THANKS ECO i WILL TRY J THOMAS, MOWING MAN MY UNIT HAS 800 HOURS AND WE CHANGE OIL AND FILTER LAST SEPTEMBER. MY BIGGEST CONCERN RIGHT NOW IS FING THE HYDROS AT THE BEST POSSIBLE PRICE BEFORE THE LEAVES START TO FALL MANY THANKS :clapping:
     
  5. Mowingman

    Mowingman LawnSite Platinum Member
    from Texas
    Posts: 4,656

    Be careful about using J.Thomas. There have been many negative comments on this forum about the VERY POOR service that folks are getting out of them. I would pay by credit card, not debit, so you can dispute the charge, if you do not get your merchandise on a timely basis.
     
  6. StihlMechanic

    StihlMechanic LawnSite Bronze Member
    Posts: 1,133

    if both wheels lack power, i would suspect the belt is slipping, the GH 600's front decks are known for the primary pulley being washed out and not gripping the belt. try replacing it first.
     
  7. joedan

    joedan LawnSite Member
    Posts: 4

    :dancing:YEP, THE PRIMARY PULLY WAS WASHED OUT I REPLACED IT AND THE HYDROS ARE ONCE AGAIN WORKING FINE I HAD ANOTHER ISSUE AND WAS NOT BOTHERING WITH IT TILL I GOT THE MACHINE TO MOVE. THE BLADES WOULD NOT ENGAGE AND WHEN I REPLACED THE FUSE (7.5) IT WOULD JUST BLOW AS SOON AS I TURNED THE IGNITION SWITCH ON. I ISOLATED THE BLADE ENGAGE SWITCH ( UN PLUGGED) AND IT STILL BLEW THE FUSE. I UNSOLDERED THE DIODE OFF THE CIRCUIT BOARD, GOES FROM THE BROWN LEAD ON THE C BOARD TO YELLOW/GREEN TERMINAL ON THE C BOARD AND THEN REPLACED THE FUSE AND NOW IT DOES'NT BLOW, BAD DIODE. NOW TO FIND THE PART # FOR THE DIODE, ANOTHER FORUM SAID IT IT 604886 AVAILABLE AT MOWPARTS .COM FOR $9 BUCKS GRASSHOPPER SERVICE MANUAL DOES NOT SHOW THIS AS A SERVICABLE PART, ANY THOUGHTS ???
    THANKS FOR SAVING ME ON THE HYDROS YOUR MY HERO
     
  8. StihlMechanic

    StihlMechanic LawnSite Bronze Member
    Posts: 1,133

    glad it worked out. I have purchased quite a few of those GH's with "bad" trannys for cheap, lol. Take the diode to radio shack, they should have one.
     

Share This Page