Great Dane Gateway mower blade clutch

Discussion in 'Mechanic and Repair' started by Steve Huxtable, Sep 8, 2013.

  1. Steve Huxtable

    Steve Huxtable LawnSite Member
    Posts: 23

    Hi I wonder if any of you guys can help a gardener over here in the uk.

    I have great dane gateway mower and I am pretty sure the electromagnetic blade clutch has gone.
    The symptoms are I have to rev the mower hard for it to engage the clutch at all. But when it hits grass the blade stops within a few feet. And there is a buzzing noise coming from on of the wiring connector blocks.

    The problem is a new clutch is £350 over here in the UK roughly $550 dollars so i dont want to but one and find it is an electrical problem.

    So is their anyway to test the clutch and wiring system.

    Thanks in advance

    Steve
     
  2. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,024

    Steve,

    Download THIS...... It's for Scag but the same will apply to adjusting (if your's is adjustable) and testing the electrical......
     
  3. Steve Huxtable

    Steve Huxtable LawnSite Member
    Posts: 23

    Thanks for that:)
     
  4. Steve Huxtable

    Steve Huxtable LawnSite Member
    Posts: 23

    Done the electrical test and it can out at lot lower resistance the stated does this mean the coil has gone?
     
  5. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,024

    What number did you get on the resistance test ?

    What did you get on the amp test ?

    Also...... is it a Warner or Ogura clutch ?
     

Share This Page