Hard steering

Discussion in 'Trucks and Trailers' started by Smither, Nov 29, 2000.

  1. Smither

    Smither LawnSite Member
    Posts: 90

    My '78 K10 is terribly hard to steer first thing in the morning when it is cold. You really have to muscle it to turn it, either direction. When the truck warms up, it's fine. I replaced the power steering pump, but I still have the problem. Anybody seen this before? What's the fix, if there is one?
     
  2. 84'GMC4x4

    84'GMC4x4 LawnSite Member
    from MA
    Posts: 84

    smither, is it hard to steer only at low/no speeds or when at driving speeds also?

    is this truck new to you or is it a new prob on a truck you already owned?
     
  3. 85w/350

    85w/350 LawnSite Member
    Posts: 244

    Checked the tension on the belt connecting to your power steering?
     
  4. Smither

    Smither LawnSite Member
    Posts: 90

    It is usually hard to steer at low speeds, because it is usually the worst when I'm leaving the house and going down the driveway and short neighborhood street. Usually clears up after about 2 miles or so, sometimes less. Never does it at speed 'cause it usually warm enough by then. This is not a NEW problem on this truck. I've had the truck a year or so. When I first got the truck, it would do this very, very slight compared to now. Usually one good tug on the wheel and it was done. I kept thinking it was ps fluid being low, but it never really went down. Kept belt tight too. Has gotten worse here just lately, especially since it's gotten colder outside.
     
  5. Fierospeeder

    Fierospeeder LawnSite Member
    Posts: 51

    Im dont own a truck yet, but i hope i will this summer.

    But my moms car has rack and pinion, and it has the same problem. I heard this before from shadetree mechanic (cable show on tv)

    The seals in the rack and pinion wear out and it makes steering difficult in those cold mornings. I think the only thing you can do is replace the rack and pinion.

    I know the truck has a different kind of a steering design. But the problem would probably be in the same area "power steering gear" where the pitman arm is connected to.
     
  6. 84'GMC4x4

    84'GMC4x4 LawnSite Member
    from MA
    Posts: 84

    was thinking the P/S fluid might be old & needing replacing but you probably did that when replacing the pump, yes?

    my truck acts somewhat similar(squeels alot when turning at very low speeds too) so i would be interested in a fix myself. i've just been to lazy to even think about it, let alone do anything about it
     
  7. Smither

    Smither LawnSite Member
    Posts: 90

    I was aware of the problems with GM cars like fierospeeder talked about. The fix there is to replace the rack. I don't see a rack, just steering gear that looks like it holds a worm gear or something. Looked in LMC truck book and new steering gear is upwards of $250. Ouch!! Didn't know if a steering gear going bad would cause the same kind of problem as a rack going bad, or if they are the same thing. Can you rebuild the steering gear? Don't really need my truck "down" this time of year. A swap would be better.
     
  8. 85w/350

    85w/350 LawnSite Member
    Posts: 244

    84' 4x4 --- your problem is probably the tension on the belt...had this problem with both my trucks...since old trucks here in the city dont get much respect(besides when i burn someone racing down the street)i was very embarasssed the first time my truck did that after i had replaced the belts...not hard to fix just make sure you keep those belts tight.....
     
  9. 84'GMC4x4

    84'GMC4x4 LawnSite Member
    from MA
    Posts: 84

    my belt is new & nice and tight, but i'm thinking it might be my pulley on P/S pump. it looks like it's seen better days. also, not sure if this is normal but when the pump & belt are in place and tight the pump tilts a little to the side(in line with belt). it's only just a little, but i'm not sure if that would cause any problems
     
  10. Smither

    Smither LawnSite Member
    Posts: 90

    My pump also tilts slightly out of line like yours does, 84GMC4x4. When i replaced my pump, couldn't get the old pulley off of the old pump. Bought a new one at the dealership. About $25.
     

Share This Page