have straight shaft 'yazoo' trimmer- it needs..

Discussion in 'Mechanic and Repair' started by mowisme, May 5, 2007.

  1. mowisme

    mowisme LawnSite Senior Member
    Posts: 893

    hi- I got this older 'yazoo' trimmer given to me as it won't run. It has some issues but does have compression and spark. I think 'Yazoo' is a commercial brand, and the fact that it has straight shaft seems to me a good reason to fix? or were they 'junk'. appears well built..but heavy. I know for fact that the centrifical clutch has come apart..and needs replaced ( if still avail.?), and due to having compression,and spark but nothing will make it even kick, I'm thinking the key may be sheared and is out of time? any input here? Is it worth the time/money to fix? I know it isn't a echo or stihl, but does appear commercial grade? thanks. p.s. my Lesco survived the misshap of gas put into oil reservoir..Motor and hydros working now. Thanks to Restorobs help Gene
     
  2. khouse

    khouse LawnSite Bronze Member
    Posts: 1,465

    I don't think the flywheel key is sheared. Even if it is you will still get a spark. Have you first checked for spark?
     
  3. mowisme

    mowisme LawnSite Senior Member
    Posts: 893

    Khouse..I do have spark..was mentioned in post but must have been overlooked- everything has beed tried That I know to get started (that isn't much thou) and can't even get a 'pop' ..thanks Gene
     
  4. MowerMedic77

    MowerMedic77 LawnSite Bronze Member
    Posts: 1,164

    Check your crank seals may have one pushed out.
     
  5. khouse

    khouse LawnSite Bronze Member
    Posts: 1,465

    Try a new spark plug
     

Share This Page