HEI Distributor upgrade

Discussion in 'Trucks and Trailers' started by jdallen, Sep 18, 2000.

  1. jdallen

    jdallen LawnSite Member
    Posts: 4

    Can anyone help me??? I have recently purchased a HEI distributor for a 74 350 at a swap meet. Before installing it I purchased a new control module, distr. cap, rotor, plugs and wires. I have also rerun the 12V wire to the
    distributor in order to bypass the resitor wire. After doing the install and cranking the engine, it there are problems. It will idle OK but as soon as there is a load on it the engine will start missing really bad. I have
    double checked the carb and moved the distributor to change the timing but nothing seams to help. I will appreciate any assistance that anyone can give.
     
  2. OBRYANMAINT

    OBRYANMAINT LawnSite Senior Member
    Posts: 555

    take it to a place that will recurve the advance tell the engine you have and the mods done i did this same thing to a 74 nova/350 had the dist rebuilt and recurved for like 80 bucks definately worth it
     
  3. BUSHMASTER

    BUSHMASTER LawnSite Senior Member
    Posts: 519

    Double check the spark plug wires,are they in order?double check that you don't have the dis.180 degrs,out.
     
  4. jdallen

    jdallen LawnSite Member
    Posts: 4

    Thanks for the advice....I had installed new wires and have double checked the firing order, also checked that the distributor is not 180 out. That only leaves the advance. I was already thinking along those lines since the idle is good, it was only when you try to drive that it messes up. I do appreciate the responses...
     
  5. John DiMartino

    John DiMartino LawnSite Silver Member
    Posts: 2,555

    Please dont take this as an insult,but if you had to buy a used distributor,then replace everything in it,you should've bought a reman unit and dropped it in,you'd of had it curved for your application,at least it'd been closer than you are now,and most carry a long warranty.Learn from this,most used parts,especially electrical are not worth anything,new units arent much more money.If i were you,unhook the vacuum advance,if this fixes it,the pickup coil isbad,the wires will rub thru over time,causing a miss when the advance pulls on the pickup.This is exactly what it sounds like,its the only thing you didnt replace too,its probably why someone sold it to you.Good luck,and check that first.
     

Share This Page