help! bad mpg

Discussion in 'Trucks and Trailers' started by lawnfreak09, Mar 30, 2009.

  1. lawnfreak09

    lawnfreak09 LawnSite Member
    Posts: 83

    i have a 97 f-150 with a 4.2 liter v6. I am getting 11 mpg without pulling the trailer. I put new plugs, wires, air filter and ran some injector cleaner. All of this has not helped. Any idea's would be much appreciated.
     
  2. J&R Landscaping

    J&R Landscaping LawnSite Fanatic
    Posts: 5,096

    How many miles on the truck? Have you replaced your PCV valve??
     
  3. 4.3mudder

    4.3mudder LawnSite Silver Member
    Posts: 2,227

    The problem is circled on the front of your grill. lol
     
  4. lawnfreak09

    lawnfreak09 LawnSite Member
    Posts: 83

    there is 102,xxx on the truck and i have not replaced the pcv valve.....
     
  5. lawnfreak09

    lawnfreak09 LawnSite Member
    Posts: 83

    must be a chevy driver
     
  6. 4.3mudder

    4.3mudder LawnSite Silver Member
    Posts: 2,227

    That would be correct.

    What did your plugs look like when you took them out?
     
  7. South Florida Lawns

    South Florida Lawns LawnSite Platinum Member
    from usa
    Posts: 4,785

    11 mpg. what's your driving style? Because i could get that all day long driving like an ******* in my 4.3 chevy.
     
  8. Edmonds Lawn Service

    Edmonds Lawn Service LawnSite Member
    Posts: 96

    i have an f150 too and i get about the same...mine is the 5.4 and its a 4x4. thats just ford for you. Chevy gets better gas milage period. I have a chevy 1500 that is lifted bigger tires and all and it still gets better gas milage than my f150
     
  9. 4.3mudder

    4.3mudder LawnSite Silver Member
    Posts: 2,227

    I think the ford tends to run richer also. I have a buddy that has a 2002 f150, and his tailpipe is black, I mean dark black, his is a v6. Maybe they have them from the factory to run rich. which, running richer will tend to use for fuel in conjunction.
     
  10. lawnfreak09

    lawnfreak09 LawnSite Member
    Posts: 83

    the plugs looked like sh** and the wires were the factory wires from 97 could not believe it. And i drive like an old man. i dont ever hot rod it....it is a v6 what is the point.lol
     

Share This Page