Help:BS Lawnmower engine stops after starting

Discussion in 'Mechanic and Repair' started by Indianrider, Apr 23, 2005.

  1. Indianrider

    Indianrider LawnSite Member
    Posts: 4

    Help, people. I would very much appreciate it.

    I have a craftsman 7 HP Lawn mower ( 2 years old) with Briggs & stratton engine. The lawn mower starts fine but it stops immediately after starting. This happens every time.

    I have replaced oil
    I have replaced gas
    I cleaned the Air filter completely
    I removed carbureator and cleaned it up completely.

    Still same problem. Always immediately stops after starting up.

    If I engage the gear, it engages and moves but it does stop immediately. So, it is not a gear problem either

    All I can think is something todo with the engine but I have no idea. Please help.

    Thanks,

    IndianRider
     
  2. Travis Followell

    Travis Followell LawnSite Silver Member
    from KY
    Posts: 2,207

    When you say you cleaned the carburetor did you completely disassemble it and clean it with carb cleaner and blow it out with compressed air?
     
  3. Indianrider

    Indianrider LawnSite Member
    Posts: 4

    No, I just removed the carb and just cleaned it with carb cleaner spray. Everything looked ok. Looks like new. Used the mower less than 50 hours only till now.

    Thanks.
     
  4. EWIRedMaxRep

    EWIRedMaxRep LawnSite Member
    Posts: 18

    Get a can of B 12 carb cleaner, remove carb and fuel bowl Shoot the carb cleaner through the main jet going up through the carb, shoot it through the inlet needle passage(where the hose hooks up) Clean the bowl, blow out everything with compressed air.Drain the Tank of all old fuel and as good practice replace the fuel line. Make sure all gaskets are in good shape reverse procedure. Go forth and Mow. Next year put fuel preservative in the fuel. Your gas has gone bad a created varnish in your carb.
     
  5. Indianrider

    Indianrider LawnSite Member
    Posts: 4

    Thanks. I will try that. I remember that I didn't clean up the bowl. So, thatz one thing I missed out.

    Thanks.
     
  6. Indianrider

    Indianrider LawnSite Member
    Posts: 4

    It does run when I keep priming it. I used some Carb cleaner from Pepboys. Is it best to get the B12 carb cleaner? Where can I get that? Also, could it be a governor problem?

    Another thing is my compressor stopped working. So, I cannot use compressed air to dry it up. Is the compressed air absolutely necessary?

    Thanks a bunch.
     
  7. Travis Followell

    Travis Followell LawnSite Silver Member
    from KY
    Posts: 2,207

    Its time to get a new compressor. The air is almost necessary to blow away the dirt after the carb cleaner breaks it lose. By it running when you prime it sounds like you've got dirt clogging the jet partially.
     
  8. mike76

    mike76 LawnSite Member
    Posts: 27

    If your aire compressor is down take torch tip cleaner or strip a piece of wire and run it through the holes in the main jet , the bolt that holds the bowl on, then spray it with the carb cleaner. If you ddn't replace the gasket between the carb and air filter base it can cause you problems like this too. Good luck
     
  9. MastercutzLawnCareII

    MastercutzLawnCareII LawnSite Member
    Posts: 27

    If you eliminate the Carb, and its not the problem I would say its the iginition switch, had a Laser Z do this, then it would run sometimes and just shut off while mowing, but toawrd the end it would start, and the die before I could even get the blades on..... seems like it was shorting out inside the switch..... also you have to have the exact switch when you replace it or it still will give you the same problems.... hope this helps.
     

Share This Page