help please, im breaking blades !!

Discussion in 'Mechanic and Repair' started by 2StripeTC, Sep 8, 2009.

  1. 2StripeTC

    2StripeTC LawnSite Member
    Posts: 20

    So my 3rd blade, furthest from the discharge keeps breaking about 1/4 of the blade off..... any idea?
  2. Two Seasons

    Two Seasons LawnSite Senior Member
    Posts: 791

    More information needed.

    Serial # of deck
  3. big_belly4ever

    big_belly4ever LawnSite Member
    Posts: 66

    May have bent one of the spindles and when the third and the second meet it snaps it? my guess.Spin with new ones on and see if they hit each other.
  4. whoopassonthebluegrass

    whoopassonthebluegrass LawnSite Platinum Member
    Posts: 4,214

    Yeah. Sure sounds like your blade isn't centered. Could it be tweaked and hitting a baffle or something? Is this a new mower?
  5. Shasta Lake Landscaping

    Shasta Lake Landscaping LawnSite Senior Member
    Posts: 436

    Sounds dangerous
  6. 2StripeTC

    2StripeTC LawnSite Member
    Posts: 20

    well commercial lawn here in town said it was the spindle, which i agreed to after listening to it and it has not broke since! Thanks guys for the response so quickly
  7. mowermankevin

    mowermankevin LawnSite Senior Member
    Posts: 270

    How many hours are on the inside blade? The left side blade will always wear quicker as there is more work to do to push the grass to the discharge side. If that is not the problem, then is the mulch kit missing bolts underneath? Like the previous post said make sure the blades spin freely and are not touching, make sure the blade P# is the correct one. I had a Lesco I switched out blades and the fella said the blades were hitting, so I went to where he was, (2nd trip) and sure enough the blades were touching, pulled 'em off looked at the numbers on the blades and they were correct, come to find out the correct number was stamped on the wrong blade, what's a person to do?

Share This Page