1. Missed the live Ask the Expert event?
    Not to worry. Check out the archived thread of the Q&A with Ken Hutcheson, President of U.S. Lawns, and the LawnSite community on the Franchising Forum.

    Dismiss Notice

Help purging hydro pump

Discussion in 'Mechanic and Repair' started by EGL&L, May 30, 2009.

  1. EGL&L

    EGL&L LawnSite Member
    Posts: 122

    Took my right side Hydro Gear pump off to inspect a leak...had it rebuilt but now can't seem to get it to purge.
    I have oil flow at the inlet hose, open relief valve, but when I start it and work the handle, I don't get anything.
    The hoses to the wheel motors were empty, as they had to come off. Do I need to do something with them?
    Am I just not letting it run long enough? I'm afraid to run too long with no oil working through the pump.
    Anyone with some insight?

    Thanks,
    Bob
     
  2. ALC-GregH

    ALC-GregH LawnSite Fanatic
    from PA
    Posts: 7,053

    Bob, how long did you let it run?
     
  3. EGL&L

    EGL&L LawnSite Member
    Posts: 122

    Not long...less than a minute. As I said, I took the service techs advice and was afraid to let it run long.
     
  4. MOW ED

    MOW ED LawnSite Fanatic
    Posts: 5,028

    I replaced the filter in my Toro Z and hand turned the hydro for many minutes after releasing the hydros then left it for a while and came back and did it again. It took a long time to burp it all out. I then left it up on jacks at a slow idle and let them spin. I don't know if I helped you or not but take it slow, air = bad in a hydro as you probably know.
     
  5. MowerMedic77

    MowerMedic77 LawnSite Bronze Member
    Posts: 1,164

    Close the relief/bypass valve......
     
  6. viper00085

    viper00085 LawnSite Member
    from NC/VA
    Posts: 237

    if it still does not come alive after running it up on jackstands, etc, quick thing to check that alot of people/techs included mess up on is the charge pump cover orientation.
    The charge pump cover is the semi-oval shaped black or gold colored very top cover usually help on by two countersunk allenhead bolts on the older pumps. If you notice the cover will have a recessed /indented mark punched off to one side of it between the bolt holes. If that got reverersed during re-assembly it will never allow the pump to charge back up. Usually on a ztr you can just compare it to the other pumps orientation and make sure there on the same way. (some units wont be orientated the same way if there spinning the pumps different rotations or have strange setups, but its rare)
     
  7. EGL&L

    EGL&L LawnSite Member
    Posts: 122

    Thanks for the input guys. I went back to the unit and checked the lines again, to be safe. Had input flow at the pump, had flow starting at the wheel motor, so I just tried again...and let it run a bit longer. Have it all worked out now.
    Thanks again.
     

Share This Page