Help with kaw fc420, carb leaks gas

Discussion in 'Mechanic and Repair' started by GoBrowns247, Apr 2, 2006.

  1. GoBrowns247

    GoBrowns247 LawnSite Member
    Posts: 9

    I recently repainted one of my mowers. It looks great. I put the engine on and it started right up. It smoked at first but the engine has been sitting for a year so I didnt worry. Figured it was water in the carb. I shut it down and came in to read some info on this site. When I returned to the mower it was leaking gas out of the tube coming out of the carb ( overflow tube ?) I dont know what to do. I have read in many threads that a good carb cleaning can do alot. I will go and clean it a few times while I wait and see if anyone has any info for me. I really dont want to take it to the shop if I dont have to. I used to mow part time and this is my first year full time. Money is tight at the moment. Any help would be great, thanks.
     
  2. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,022

    If cleaning doesn't fix the problem the float needle valve may have gotten hard from sitting and needs to be replaced.
     
  3. GoBrowns247

    GoBrowns247 LawnSite Member
    Posts: 9

    Thanks Rob, It was the needle. Now it runs great, untill I turn on the blades. Then it dies out. Any help ?
     
  4. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,022

    If it runs great without the blades engaged I would want to think a problem with a safety switch possibly killing spark. ?
     

Share This Page