honda gx620 surging at WOT

Discussion in 'Mechanic and Repair' started by JRS Landscaping, Jan 28, 2014.

  1. JRS Landscaping

    JRS Landscaping LawnSite Senior Member
    Posts: 817

    First some back round. It has 170 hours on it. Its on an engine drive welder. I took the carb off and looked it was really clean but I cleaned it anyway. I used a torch tip cleaner in all the little jet holes. Still surges at WOT. Does not surge at idle! Only time it doesn't surge at WOT is when i pull the choke out a little bit. Im stumped. I clean the carb like 3 times. Only thing i noticed is fuel filter Barley fills up when running? maybe lack of fuel? any way to test fuel pump? Unit was sitting for a while. Drained out old gas and put some new in too.
     
  2. JRS Landscaping

    JRS Landscaping LawnSite Senior Member
    Posts: 817

    Update. ruled out fuel pump. Ran a gravity fed line from tank above machine. Still doing same thing!
     
  3. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,023

    Did you grind the ear/tab off the low speed adjuster and remove it for port cleaning ?

    If not give that a try, Count the turns screwing in before removal then count that many turns back out from closed but add another half to one turn......
     
  4. JRS Landscaping

    JRS Landscaping LawnSite Senior Member
    Posts: 817

    yes i did with a dremel! adjusted it while running still nothing! :cry:
     
  5. Landrus2

    Landrus2 LawnSite Platinum Member
    Posts: 4,833

    Hey rob can you display on carb where to grind:waving:

    image.jpg
     
  6. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,023

    That carb doesn't have the same style adjuster......


    [​IMG]


    JRS..... Sure sounds like it's running a bit lean, Try this.....With the engine cool start and run it up till it surges then spray carb & choke cleaner around the carb base gasket and both intake gaskets, If it changes tune replace the needed gaskets.....

    Have you tried a new set of plugs just for giggles ?
     
  7. JRS Landscaping

    JRS Landscaping LawnSite Senior Member
    Posts: 817


    Yes new plugs and oil. Old air filter. Both plugs get spark and notice if i unplug one while its running it sounds normal. I will try what you said tomorrow. Any clue what that upper nipple is for? is it just a vent? or does a tube go on it? there was nothing there when i got the machine and can't find any info on it. It does run better when i put my finger over it to block air flow. Seems like its getting too much air somehow.
     
  8. JRS Landscaping

    JRS Landscaping LawnSite Senior Member
    Posts: 817

    Tried spraying the carb and intake gaskets. Nothing Same surge. Must be something internal with carb?
     
  9. BigFish

    BigFish LawnSite Gold Member
    Posts: 3,362

    You prolly missed something when ya cleaned it. Prolly the pilot jet. Ya need a VERY fine wire to clean it! I used to use a single wire from a hand wire brush. A "tag" wire is too big a dia.
     
  10. Landrus2

    Landrus2 LawnSite Platinum Member
    Posts: 4,833

    That will work

    image.jpg
     

Share This Page