Husqvarna 145 blower problems

Discussion in 'Mechanic and Repair' started by jarroo's lawncare, Oct 22, 2005.

  1. jarroo's lawncare

    jarroo's lawncare LawnSite Member
    Posts: 116

    the throttle cable on the blower was binding up and i fix it but now it runs good and bogs down and almost dies if you keep the throttle open i checked the plug and it was good but the filter was soaked in gas. i think the carburetor is messed up but it is under warranty what could be wrong.
     
  2. lawnmaniac883

    lawnmaniac883 LawnSite Silver Member
    Posts: 2,613

    Check the primer bulb, sometimes they crack or break. Also, your high speed adjustment is out of spec, the transition between idle to WOT indicates this when it bogs down. Turn the high speed adjustment screw in all the way, until snug, then back it out 1 1/4 turns. This should get you running in WOT, then fine tune it from there. Hope this helps.
     
  3. sildoc

    sildoc LawnSite Silver Member
    Posts: 2,925

    What was said above.
    AND. Make sure your choke is not on. I find that it sometimes gets caught while pulling it out and then when you pull the trigger it boggs baddly. Simple fix.
     
  4. ffemt1271

    ffemt1271 LawnSite Bronze Member
    Posts: 1,285

    i rebuilt one i found in a mower junk yard, it did the same thing, under the fuel cap is a pigtail that you can undo, it is the fuel tank vent, the unit was pulling a vacuum on my tank when i throttled it up. sounds like the same problem you are having.
     

Share This Page