Husqvarna 350BT will not start, checked everything. Need your help!

Discussion in 'Mechanic and Repair' started by scottycam, Nov 16, 2011.

  1. scottycam

    scottycam LawnSite Member
    from MA
    Posts: 11

    This has been resolved. I'm not sure what may have fixed it since I decided to go through the entire carb cleaning process all over for the 20th time and it seems to be good now. Starts up after a few pulls and no longer need any fuel added to the spark plug hole.


    I thoguht more about how I needed to add teh fuel mix in order to start. So that brought me to the primer bulb.. That checked out ok, no cracks or pinholes. Then made sure the fuel line was ok. Ruled out the easy parts..

    Then I took out the jet, replaced the O-ring and also spray through the nozzle. No Obstruction.
    Adjusted the seat to make it run a little richer. Sprayed some carb spray and made sure that it dripped through the jet. It did.

    Put everything back together, screwing things in tighter than ever and it works. Primer bulb gets stuck here and there, but I think its just because its supersealed as opposed to having a leak. When I push the primer, there's a good amount of resistance, which makes me believe that its working.


    Thanks Everyone.. As an IT person, I now know how to rebuild carburetors, for Husqvarna leafblowers, that's made by Walbro, model number wya -79. :) I was determined NOT to send it out for service and the gratification of the resolution is priceless.



    Now to start on my new venture, repairing leafblowers.... with carb issues. :cool2:
     
  2. kubotaorange

    kubotaorange LawnSite Member
    Posts: 47

    Nice man! The satisfaction of fixing it yourself is awesome isn't it!
     

Share This Page