Hustler S/Z 28EFI

Discussion in 'Hustler Turf Equip (Archived)' started by jhsmith4, Sep 10, 2007.

  1. jhsmith4

    jhsmith4 LawnSite Member
    from Ga
    Posts: 110

    I just took delivery of Super Z 60/28EFI today 09/10/07. On start-up there is heavy blue smoke coming out of the exhaust. Is this normal for a new machine during break-in or should I contact my dealer?
     
  2. mowerconsultant

    mowerconsultant LawnSite Fanatic
    Male, from Syracuse, NY
    Posts: 9,760

    I would check the engine oil level, if its between the marks then I would just note it with the dealer and watch it for the first 25 to 50 hours.
    It vary well may be the rings not set in yet.
     
  3. tshank

    tshank LawnSite Member
    Posts: 201

    Same thing on a 30hp. If I shut down with the rpm's up it will sometimes smoke heavily. Usually let it idle down before shutdown and rarely have smoke. Must be a Kohler thing 'cause a 25 I had did the same thing.
     
  4. puppypaws

    puppypaws LawnSite Fanatic
    Posts: 8,905

    I have 275 hrs. on my 2006 28 efi and it has never smoked once on startup or any other time so you can believe there is something that causes this to happen.
     
  5. Imow4u2

    Imow4u2 LawnSite Senior Member
    Posts: 377

    Little over 600 hrs. on mine, no smoke.. Been a long wet season here and I have run the dogsh!t out of mine.. It uses some oil but never any visable smoke...
     
  6. 3Bladz

    3Bladz LawnSite Member
    from IL
    Posts: 168

    All my Kohler vertical shaft engines have done this since new. They were supposed to have fixed this as of the 2006 engines. But it still does it just the same. I dont think I will buy another vertical crank powered mower.
     

Share This Page