hustler super Z help...

Discussion in 'Lawn Mowing' started by Ever Green, Jun 28, 2006.

  1. Ever Green

    Ever Green LawnSite Member
    Posts: 31

    Have new super z with 60" xr7 deck and 30 hp problem is that the mower is leaving a strip about 4" wide that is not cut. It appears to be coming from far left blade near middle blade ---if your sitting on mower---Whats going on with this thing...I'm tired of cutting everything twice...please has yet to return my call...
  2. JTF40

    JTF40 LawnSite Senior Member
    Posts: 875

    The first thing that I would check is to see if the "tips" of the blades are worn/rounded. If so, sharpen/replace them. :usflag:
  3. tacoma200

    tacoma200 LawnSite Fanatic
    Posts: 5,426

    Sounds like you are one of the unlucky ones thats needs the fix from Hustler. They are supplying it free of charge to customers with this problem. Get your dealer to return your call or call the factory direct and tell them of the problem. If you will go to he Hustler forum on lawnsite there are many post with this problem and Hustler has been on the ball getting it fixed. Can't comment on your dealer but Hustler in general will get right on it. Go to the dealer and ask for the boss, you deserve to have it fixed imediatelly. Have them air mail the parts at thier expense if necessary. Good luck. If its a new mower as you say they should be tripping all over themselves to fix the problem. You'll get more replies.
  4. mowerconsultant

    mowerconsultant LawnSite Fanatic
    Male, from Syracuse, NY
    Posts: 9,761

    I just received your e-mail.
    I will call you in the am.

  5. TLS

    TLS LawnSite Fanatic
    Posts: 7,937

    This baffle will have this problem portion of grass being cut just as well as the rest of the deck.

    There are no downsides to having this baffle installed.
  6. tacoma200

    tacoma200 LawnSite Fanatic
    Posts: 5,426

    Told ya they would get right on it..... Good job Hustler...
  7. Idealtim

    Idealtim LawnSite Senior Member
    Posts: 939

    Why couldn't exmark do this for the guy who had a post on here about the triton deck giving him a problem?
  8. TLS

    TLS LawnSite Fanatic
    Posts: 7,937

    Simple....they don't have a fix for it.
  9. specialtylc

    specialtylc LawnSite Bronze Member
    Posts: 1,656

    Its likely the grass is getting laid down by the front tire and the blades are not lifting it up enough to fully cut. I have had similar problem with different brands of mowers. Tall grass mowed at a tall height, 3.5 inches to more. 3 inches and lower eliminates the problem.

Share This Page