1. Missed the live Ask the Expert event?
    Not to worry. Check out the archived thread of the Q&A with Ken Hutcheson, President of U.S. Lawns, and the LawnSite community in the Franchising forum .

    Dismiss Notice

Hydro knock

Discussion in 'Mechanic and Repair' started by ashgrove landscaping, Apr 3, 2012.

  1. ashgrove landscaping

    ashgrove landscaping LawnSite Gold Member
    Posts: 3,463

    Before I say anything, I've searched a ton already and am not satisfied. My left hydro pump is making a knocking sound and my ferris 2000z. Everything runs great, no weakness or pulling on either side just this knock/rattle coming from the left pump. I put my ear right up to it so I'm sure it is that one. Is the pump going bad or is there a fix?? Any thoughts/suggestions?
  2. cgaengineer

    cgaengineer LawnSite Fanatic
    Posts: 15,782

    Are you sure it's not the belt tensioner making the noise...I've had a similar problem on my toro and it turned out to be tensioner bolt was loose.
    Posted via Mobile Device
  3. ashgrove landscaping

    ashgrove landscaping LawnSite Gold Member
    Posts: 3,463

    Pretty sure. The noise is directly on the pump. I guess Ill just wait until there is a change in performance before anything is done.
  4. orangemower

    orangemower LawnSite Silver Member
    from pa
    Posts: 2,773

    Use a long screwdriver or rod and carefully touch the parts you suspect are bad. It will give you a better idea if it's what's making the noise. Similar to a stethoscope. I actually have a stethoscope with a thin rod on the end about 20in long to listen for bearing noise in autos.
  5. piston slapper

    piston slapper LawnSite Platinum Member
    Posts: 4,240

    Time to put a magnet in the hydro tank....look for metal shavings
    There may be a party going on inside the pump...I've caught quite a few of them before they let go, and was able to repair them...When it stops knocking , its usually replacement time....
  6. TEKracing37

    TEKracing37 LawnSite Member
    Posts: 17

    I have this exact problem on my 1500z...It's only got 137 hours on it.
    I can put my hand on the left pump fan cover and feel it knocking/vibrating. It started during this last week's mow.

    I bought it in May of 2009 so, i think it's out of warranty. I only use it about 50 hours per year to mow 2 acres.
    I believe the warranty was for 2 years...Do you think they should/will fix it under warranty? Should I ask?
  7. piston slapper

    piston slapper LawnSite Platinum Member
    Posts: 4,240

    Warraties are in years...not amount of use...
    Not saying its out of the question.....its gonna take a good conversation...
    Posted via Mobile Device
  8. Carl_NH

    Carl_NH LawnSite Member
    Posts: 7

    I have the Ferris IS2000 25/52 60 hrs now -purchased as an 09 leftover in June 2010 and noticed the hydro noise too. I did isolate it to the fans on the top of the hydro rattling at a low speed.

    BUT I also am anal about fluids/dirty oil and my hydro oil had a sort of burnt smell and was as dirty as used gas engine oil. Hydro's should not have dark fluid in my opinion (my Kubota TLB was clean as new oil @ 300 hr change). So last weekend I changed out the filter with a new 51563 Hydrogear filter and 1 3/4 quarts of 15/50 Mobil one.

    Also here is a link to tractor by net of another Ferris IS3100 owner - had the bearings on the bottom of the right side HydroGear pump bite the dust at 130 hours. http://www.tractorbynet.com/forums/general-lawn-garden/245454-hydro-gear-pj-12-pump.html

    I hope there is NO corelation to dirty oil/noisy pumps/bad bearings in the 09-10 Hydrogear pumps with low hours..


Share This Page