I have one of the Walmart mowers

Discussion in 'Mechanic and Repair' started by briggsman65, May 5, 2007.

  1. briggsman65

    briggsman65 LawnSite Member
    Posts: 22

    It is a 3.5 horsepower briggs motor. ( model #9D902) When I start the mower up it runs weird. It runs at an up and down speed. Runs full idle then almost dies repeatedly. I took the carburator off and cleaned it. I cleaned the fly wheel and the armature. I changed the oil. I changed the spark plug. I also changed the air filter. The only thing I am noticing that is odd, is the spark plug keeps turning black. I can clean it and put it back in and it turns black again. I can't think of anything else to do. HELP!!!!!!

    Thank-you ahead of time for your help.
     
  2. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,024

    In what way did you clean the carb. ?

    Did you make sure the main jet was fully open (not restricted) ?

    Did you install a new diaphragm ?

    Sounds like it's running lean causing the hunt (up/down running). When a engine does this every time it goes up it's pulling more fuel than required to maintain a steady speed, That could account for the black plug.
     
  3. briggsman65

    briggsman65 LawnSite Member
    Posts: 22

    I just took it off of the gas tank and sprayed it with the carb cleaner. it is one of those "fancy" plastic carburators. I cleaned the screen and the pick up tube and all of the dirt. I did not replace the diaphragm. Do you think that it needs to be replaced? I didn't really pay attention to the main jet as far as adjusting. Didn't see how you would open it up.
     
  4. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,024

    The main jet is shown below. There is no adjustment, Spray cleaner through it and make sure it's open. I would suggest replacing the diaphragm. These plastic carbs are not the best at sealing.


    [​IMG]
     
  5. briggsman65

    briggsman65 LawnSite Member
    Posts: 22

    Cool.................Thanks I will try this and also thanks for the diagram with the part numbers.:)
     
  6. Bill Kapaun

    Bill Kapaun LawnSite Senior Member
    Posts: 917

    Just curious-
    Does that carb have a choke?
     
  7. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,024

    No Bill, It has a primer bulb and reference # 913 is the primer check valve assembly. I don't remember ever having a problem with this assembly to cause a rich run/hunt situation but anything is possible.
     
  8. briggsman65

    briggsman65 LawnSite Member
    Posts: 22

    No choke...........just as Rob is saying. I will order diaphragm tomorrow and let you know if it works when I get it.
     
  9. Bill Kapaun

    Bill Kapaun LawnSite Senior Member
    Posts: 917

  10. Turfinator1

    Turfinator1 LawnSite Member
    Posts: 58

    I Brought a power washer with a briggs on it and i took it back the next day because it would take 15 pulls to get it started and it would run for hour and then I would shut it off and then I would have to pull and pull and choke it after it had been running to get it back started.
     

Share This Page