Is my pump dead?

Discussion in 'Power Washing' started by mosmgras, Apr 14, 2007.

  1. mosmgras

    mosmgras LawnSite Senior Member
    from NC
    Posts: 270

    Ok,

    I have a small pressure washer (Crapsman) 5.5 hp/2.5 gpm. I got a really great deal on it and use it to wash my equipment. Here's the thing, a few days ago, it stopped reducing pressure when I release the trigger. In order to keep the engine running, I have to hold the trigger. Every time I release the trigger, the engine bogs down and stops. I take it that this is a pump problem. Is this something I can fix or is it time for a new one? Thanks guys.
     
  2. Jason Rose

    Jason Rose LawnSite Fanatic
    Posts: 5,858

    we need to get our 2 pumps together... I have the same pressure washer, and mine reduces pressure fine, but mine won't go back to pressure when I pull the trigger! Drives me nuts, I have to keep the thing blasting all the time, cause if I let off the trigger I have to go over and flip the water off for a couple seconds and then back on to get it to pressure up again.
     
  3. FCPWLLC

    FCPWLLC LawnSite Senior Member
    Posts: 352

    Sounds like an unloader problem. A machine like that would be better to just replace vs fixing.
     
  4. mosmgras

    mosmgras LawnSite Senior Member
    from NC
    Posts: 270

    Yea... I was afraid of that.

    Oh well, it's been good to me for a while. I just looked at Northern's Northstar Professional Series, 3 gpm - 3200 psi, 9 hp Honda unit. Looks like it comes with a Cat pump. $900 and tax. Holy smoke... I have $150 in the one that just died. Guess I'm over due for an upgrade.
     
  5. FCPWLLC

    FCPWLLC LawnSite Senior Member
    Posts: 352

Share This Page