jd 757 problems

Discussion in 'Mechanic and Repair' started by copeblk, Sep 2, 2006.

  1. copeblk

    copeblk LawnSite Member
    Posts: 85

    our 757 ran fine all day execept on the last lawn, has 25hp kawi. idles fine, even at full throtle fine, engage mower and it almost want to stall. air filter replace 1 week ago, fuel filter 2 wees ago, oil changed 17 hrs ago, happened really fast, do we need new plugs, wires. was wondering if it's the fuel pump.(dont even say it , YES the mower had gas) any info would help
     
  2. stumper1620

    stumper1620 LawnSite Bronze Member
    Posts: 1,889

    pull off your deck drive belt, see what it does, I would bet you have a siezed double pully bearing. I have replaced 2 of them since I got my 737.
     
  3. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,022

    You may check your blade spindles and any idler pulleys, You may have one trying to lock up.

    So you beat me to it Steve lol
     
  4. stumper1620

    stumper1620 LawnSite Bronze Member
    Posts: 1,889

    2 Pulleys in 300 hours at 60 bucks each, I have a little experiance with these.
    the last one was supposed to be an improved part, but it still dont have a zerk so i doubt it will last. thats a JD weak link.
     
  5. copeblk

    copeblk LawnSite Member
    Posts: 85

    well now i know it not the deck went and pulled the belt, started it up idled fine, clutch engaged fine and still ran fine.disengaged clutch went to full throtle and runs like sh.. almos like choke is on, pulled air cleaner off, choke is not closed... carb need cleaning? mabey jets need adj. or replace... any more thoughts..
     
  6. stumper1620

    stumper1620 LawnSite Bronze Member
    Posts: 1,889

    possibly one bad spark plug. I would try 2 new plugs.
    I haven't had any problems with my kawi other than plugs. and the JD bearings.
     
  7. stumper1620

    stumper1620 LawnSite Bronze Member
    Posts: 1,889

    Oh, by the way, How many hours on this motor? Valve adjust?
     
  8. copeblk

    copeblk LawnSite Member
    Posts: 85

    975 hrs. could need valne adj now that i think of it but also with this many hous could need a new mower, there are probably a lot of things it needs done. we are kind of lucky i guess this is the first problem with it. never had a prob with bearings or spindles.
     
  9. stumper1620

    stumper1620 LawnSite Bronze Member
    Posts: 1,889

    I've never had spindle problems. Just the double deck drive pulley bearing, replaced one and less than 150 hours later replaced it again.
    I did have a major loss of power from a bad plug that only seemed to miss under load. also, check that the air flow through the shrouds is clear.
    My manual says every 300 hours for a valve adjust.
     
  10. stumper1620

    stumper1620 LawnSite Bronze Member
    Posts: 1,889

    Where are you Rob? Need more input from you.
     

Share This Page