john deere bagger problem

Discussion in 'Lawn Mowing' started by Matt'slawncare, May 12, 2002.

  1. Matt'slawncare

    Matt'slawncare LawnSite Member
    Posts: 145

    Yes i have a john deere front mount zero turn and when ever i use the bagger the grass and leaves always blow out under the cover. But this year i bought new bags and that still didn't help. i put on a different piece so it would pull the cover farther down but no luck. So i was just wondering if anyone had any idea's to help me solve it.
  2. wxmn6

    wxmn6 LawnSite Member
    Posts: 163

    What kind of bagger are you using?
  3. bridges

    bridges LawnSite Member
    from RI
    Posts: 196

    I have a jd ztrack too.

    Not sure what you mean when you say you had by more bags.

    The problem I had with mine was, under the vac i would get a hole in there and the clippings would come out that way. Or you don't have your back door closed right. and is your screen clear.

    Lets see a photo of this setup.

  4. Matt'slawncare

    Matt'slawncare LawnSite Member
    Posts: 145

    I have that same problems with the hole under the vac, but it dont throw clippings out. What did you do to solve that problem? I would like to solve it before clippings are getting thrown out.
  5. heather

    heather LawnSite Member
    Posts: 59

    our z track blew a hole in the vac's fan shroud. we fastened stainless steal plates over the holes. Not been happy with that plastic set up. when we had to replace the fan bering it ran $750. When the vac has a major break next time,we are taking off the bagging system. :alien:

Share This Page