Kawasaki 17hp motor problems

Discussion in 'Mechanic and Repair' started by Premo Services, May 18, 2002.

  1. Premo Services

    Premo Services LawnSite Bronze Member
    Posts: 1,516

    I have a 17 horespower kaw motor and it surges up and down, especially when it is in full throttle and blades are disengaged. It doesn't do it in low idle. Also when I am cutting, it acts like te choke is going on at times, If I take the air cleaner cover off and play with the choke, it will come out of it. I have drained the tank, changed the filter, plugs, cleaned the jets with spray cleaner and it still does it. I wonder you might have any ideas on what to do.
    Thanks
    AL
     
  2. khouse

    khouse LawnSite Bronze Member
    Posts: 1,465

    When it messes up is there black smoke coming out of the exhaust? Probably not. Sounds like the main jet is plugged a little or there could be water in the bowl. Either way I would remove the carb and check it out. Clean and blow it out with compressed air and that should do it. Also check the fuel delivery system ie. fuel filter,hose and clean tank and fuel. If theres a fuel filter change it out also.
     
  3. Premo Services

    Premo Services LawnSite Bronze Member
    Posts: 1,516

    You know, it started again today and the blades re engaged, and went down to lower rpms, and popping from carb area. I think thetre was some black smoke. Mabey that smoke was after I was playing with the choke to make it do better.:eek:
     
  4. khouse

    khouse LawnSite Bronze Member
    Posts: 1,465

    some of the things your describing sounds like it could also be starving for fuel, not running rich. when it starts doing it again loosen the fuel cap so it can draw some air. you may have a vent problem in the cap. let me know.....
     
  5. laina

    laina LawnSite Member
    Posts: 4

    you might check with your local Kawasaki warranty dealer...i hear they have had some problems with some of the Kaw twin w/ black smoke on cold start. Get the model and serial numbers off the engine block so they can check your serial number range.
     
  6. GOFlick

    GOFlick LawnSite Member
    Posts: 8

    You may want to check the tension of your belts that turn the blades. I've found that if they are too loose that they slide which cause the surging that you are describing.
    Good luck,
    Flick
     
  7. Scraper

    Scraper LawnSite Bronze Member
    Posts: 1,656

    I am experiencing the same problem on my 17 Kawi. I changed out plugs, fuel filter, and air filter last night with no help. Figure it out yet Premo?
     
  8. Premo Services

    Premo Services LawnSite Bronze Member
    Posts: 1,516

    I did what khouse mentioned about the machine starvig for gas. I took the gas cap off and took out the gasket and cleaned it real good. This has worked for quite a while now. When it would star to mess up like that I would loosen the cap and it would even out, so cleaning the cap and gasket worked. Got my fingers crossed!!!!!!!!!!!
    Thanks for the help fellows;) :D :cool:
     

Share This Page