Kawasaki 29 DFI " Where is the Green Stuff"

Discussion in 'Lawn Mowing' started by bladecutter582, Jul 16, 2008.

  1. bladecutter582

    bladecutter582 LawnSite Member
    Posts: 127

    I only have 21 hrs on my new Scag TT / 29 Kaw DFI and love it. When I took the unit home I noticed that the radiator cap had a scrape across the top, and didn't give it a second thought. When the mower had 5-7 hours on it I notice it had lost 1/3 of the antifreeze out of the holding tank on the side engine. I never have been able to see or discover where the coolant has gone. As of this week I had only one ounce of fluid left. My dealer ordered me a new cap and it seems to be a litter tighter fit ( I think). I'll post if the "leaking" stops.

    Anyone else have this problem with the coolant from this engine?

  2. jaybird24

    jaybird24 LawnSite Senior Member
    from midwest
    Posts: 623

    On the Scag L/C Kawis they use a cheap reservoir that always leaks at the caps. Probably on some other mowers too, I'm just familiar with the Scag version. None of the caps work, just carry some spare coolant pre- mixed. It doesn't really cause a problem, just an inconvenience, I would think Scag would have modified it by now.
  3. kawasakitech

    kawasakitech LawnSite Member
    Posts: 11

    49109-2057 and 92093-2122 will help prevent coolant loss from bumpy conditions.
  4. bladecutter582

    bladecutter582 LawnSite Member
    Posts: 127

    Guys I do appreciate you giving me some imfo. on this problem. I was hoping it was something that others knew about. Kawasakitech are these part #'s another cap, (what are they) ?

Share This Page