kawasaki engine

Discussion in 'Hustler Turf Equip (Archived)' started by Shawn Burns, Jul 5, 2001.

  1. Shawn Burns

    Shawn Burns LawnSite Member
    from N.C.
    Posts: 181

    i bought a hustler z this spring and so far have been very pleased with it. i have sold 4 to other grass mowers for the local dealers if that tells you anything! the question i have is about the 23 horse kawi. it started surging at about 40 hrs. and the dealer cleaned, and then replaced the carb. problem fixed... or not. now i can only engauge the blades at full throttle or the motor dies out. i hate to have to continue full rpm engaugement. any ideas?
     
  2. mowerconsultant

    mowerconsultant LawnSite Fanatic
    Male, from Syracuse, NY
    Posts: 9,760

    When the carburetor was replaced did this fix the problem ? if so for how long ?
    It sounds like there is something plugging up one of the passages (jets) in the carburetor.
    When your carburetor was replaced, did the dealer empty the fuel tanks and clean them ? and replace the fuel filter ?

    Pj
     
  3. Shawn Burns

    Shawn Burns LawnSite Member
    from N.C.
    Posts: 181

    yes, the tanks were cleaned, i'm not sure about the filter though. the replaced carb. fixed the surging problem, but thats when the other problem started.( the engine dying out when i start blades)other than that it runs like a champ!
     
  4. mowerconsultant

    mowerconsultant LawnSite Fanatic
    Male, from Syracuse, NY
    Posts: 9,760

    Sounds like the carb needs to be adjusted.
     
  5. Shawn Burns

    Shawn Burns LawnSite Member
    from N.C.
    Posts: 181

    i hope that's all it is! i think i'll have time to get by the dealer this week so they can check it out for me. talking with the mechanic at the dealer , he ddn't think that was the problem though. we'll find out! also, are yall making the stickers that go on the tank yet? mine have about rubbed off.
     

Share This Page