Kawasaki KHT 750S hedge trimmer...DOA

Discussion in 'Mechanic and Repair' started by Golf42, Sep 4, 2006.

  1. Golf42

    Golf42 LawnSite Member
    Posts: 28

    Yes I finally got my new Kawasaki hedge trimmer and the blades will not move. I'm very digusted to say the least. Probably will be my first and last piece of Kawasaki equipment.
     
  2. khouse

    khouse LawnSite Bronze Member
    Posts: 1,465

    does it have a safety stuck on the blades for shipping or handling?
     
  3. MowerMedic77

    MowerMedic77 LawnSite Bronze Member
    Posts: 1,164

    One of the blade bolts is probably too tight, your dealer did not do a setup on the new unit?
     
  4. Golf42

    Golf42 LawnSite Member
    Posts: 28

    I removed that.:rolleyes:
     
  5. Golf42

    Golf42 LawnSite Member
    Posts: 28

    Don't know for sure.
     
  6. khouse

    khouse LawnSite Bronze Member
    Posts: 1,465

    are you trying to move the blades by hand or are they too tight for the engine to move?
     
  7. MowerMedic77

    MowerMedic77 LawnSite Bronze Member
    Posts: 1,164

    Give it a quick check, with the unit OFF PLEASE:) turn it upside down so you can see the blade bolt heads and the washers you should be able to move the washers with your fingers if you can't then that is the bolt(s) keeping your blades from moving.
     
  8. Golf42

    Golf42 LawnSite Member
    Posts: 28

    That was the problem. Thanks for your help!
     
  9. MowerMedic77

    MowerMedic77 LawnSite Bronze Member
    Posts: 1,164

    Glad to hear this was your issue :) Don't give up on the Kawi's they are pretty good 2cycle equipment.
     
  10. ChadsLawn

    ChadsLawn LawnSite Bronze Member
    Posts: 1,110

    now go and spray them with some fluid film to keep them lubed and sharp for years..
     

Share This Page