1. Missed the live Ask the Expert event?
    Not to worry. Check out the archived thread of the Q&A with Ken Hutcheson, President of U.S. Lawns, and the LawnSite community in the Franchising forum .

    Dismiss Notice

kawi hedge trimmers

Discussion in 'Mechanic and Repair' started by brinlee lawn, Jan 22, 2005.

  1. brinlee lawn

    brinlee lawn LawnSite Senior Member
    Posts: 273

    I have some kawi trimmers, when you first start them up they run great but after they warm up a little bit they die, you can start them right back up run for a min. and die, then the next time you start them they may run great for a few min. and then die again. anybody have any suggestions????
  2. Travis Followell

    Travis Followell LawnSite Silver Member
    from KY
    Posts: 2,207

    Might try replacing the fuel filter and clean the spark arrestor screen and see if that helps. You may have a bad ignition module by the machine dying when it gets hot. Hope that helps.
  3. brinlee lawn

    brinlee lawn LawnSite Senior Member
    Posts: 273

    Thanks for the reply, I thought about the fuel filter but hadnt thought about the spark arrestor.
  4. mower_medic

    mower_medic LawnSite Member
    Posts: 77

    A lot of the newer Kawasaki 2 cycle equipment do that if the rubber piece inside of the gas cap is missing or gets too soft. Has something to do with the venting of the gas tank. you can replace the entire gas cap with the new rubber piece for about $5.00 (part number is 99996-6060)

Share This Page