Kawi spitting oil out filler

Discussion in 'Lawn Mowing' started by Darryl G, Apr 26, 2003.

  1. Darryl G

    Darryl G LawnSite Fanatic
    Posts: 8,133

    My 17 HP Kawasaki is spitting oil out the top of the oil fill cap. Could this be caused by an uneven idle (low speed jet is clogged again-darn it)? Will this cause the oil to splash?

    It's not loosing a lot and it only seems to happen when I'm bagging and idle it down to dump.
     
  2. Nozzleman

    Nozzleman LawnSite Member
    Posts: 225

    I am confused, is your oil fill cap not screwed on tight? Are you overfilling your engine? Could it be you cross threaded the fill cap.

    Give us more info....
     
  3. Darryl G

    Darryl G LawnSite Fanatic
    Posts: 8,133

    The fill cap is on tight, not overfilled, not cross threaded. I noticed there's no gasket seal of any sort on the cap, so pulled one out of a new machine at the dealer and no gasket on that one either. I presume one isn't needed because the oil isn't supposed to be there in the first place.
     
  4. My 23hp has an O-Ring in the filler cap. My 17hp has the same thing, but it won't stay put in the cap. When I take the cap off, the O-Ring sits on top of the filler-tube. If I'm not careful that thing will drop off the top the filler-tube one of these days.

    That still doesn't explain what's happening on your engine. I can't think of a logical reason oil is getting up to the top of that tube with enough pressure to move past those threads.
     
  5. Richard Martin

    Richard Martin LawnSite Fanatic
    Posts: 14,700

    You can check the vent tube that goes to the air cleaner. A small critter may have decided that it was the perfect size to make a cocoon in.
     
  6. Darryl G

    Darryl G LawnSite Fanatic
    Posts: 8,133

    Thanks guys. Maybe my O ring fell off when I wasn't looking and same with the one at the dealer. I'll check the vent.

    I'll also pull the carb and clean it when I get a chance.

    Does anyone else have problems with the low speed jet clogging?

    I guess I just want to make sure that this isn't indicative of a more serious problem.
     
  7. LawnGuy73

    LawnGuy73 LawnSite Bronze Member
    Posts: 1,945

    Yup, our 17 kawi does the same thing, I don't why? Its done it for about a year now, it does'nt do it to bad so we never bothered...Maybe they will recall the dipstick on that model...lol right!:rolleyes:
     
  8. Nozzleman

    Nozzleman LawnSite Member
    Posts: 225

    My 17 Kawi has no o-ring on the cap either. When it was new (last spring) I went back to the dealer because I thought I got a bad cap but the dealer checked every 17 he had and not one had an o-ring. For the record my 14hp Kawi has an o-ring on it.
     

Share This Page