Kohler Command 25 hp HELP

Discussion in 'Mechanic and Repair' started by tjcezar, Mar 26, 2006.

  1. tjcezar

    tjcezar LawnSite Member
    from PA
    Posts: 237

    I just bought a Kohler Command 25 hp engine used and I want to test it on my work bench. I hooked everything up like gas and battery to jump start it. It turns over and has great compression but I am not getting spark. There is an electrical plug that comes out of the unit so does this need some attention or need to be plugged into something in order for me to get spark to the plugs? Please help.:dancing:
     
  2. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,022

    Does this engine have the SAM spark ignition (a black box mounted on the blower housing) ? Best just post the model and spec. numbers so we can see what system you have, 12 volts to the wrong wire could damage the system.
     
  3. tjcezar

    tjcezar LawnSite Member
    from PA
    Posts: 237

    model CV730s
    spec CV730 0020
     
  4. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,022

    OK, There is a white wire in the plug connector on the side of the engine, This is the kill wire and runs to each coil under the blower housing. It is possible this wire is shorted under the housing, Remove the housing and disconnect these wires from each coil and test for spark again. If still no spark both coils are bad, It's possible 12 volts was introduced to this white wire at some point and blew both coils.
    You also have a fuel cut-off solenoid on the carb. bowl that needs 12 volts applied to in order to bench run the engine, There is a plug along side the carb. that can be disconnected and a jumper wire installed to take care of this. Below is the wire diagram for this engine to give you a better idea.

    BTW, This engine came off a John Deere

    Good Luck

    CV25 Ignition System.JPG
     
  5. tjcezar

    tjcezar LawnSite Member
    from PA
    Posts: 237

    Thanks a bunch! I will try this later today. Your input has been GREATLY appreciated. I will repost after I try it out:usflag:
     

Share This Page