kohler fuel pump

Discussion in 'Mechanic and Repair' started by tomo, Oct 1, 2006.

  1. tomo

    tomo LawnSite Senior Member
    Posts: 660

    Hello, any body ever seen the valve cover[valve train operated ] fuel pump leak and dump fuel into sump [plunger is loose where it connects to diaphram]. Also on my own engine it decided to dissassemble it self ,plunger disconnected itself from actuator arm.Yes it must be in engine somewhere[clip etc] !!!!! Find on next rebuild.Eng is ch25s. Converted back to pulse pump set up.Original eng is 68544 walker, fuel pump from dingo mini digger ch25s. Pulse line runs to close to exhaust and does not last to long b4 it is brittle.This is a small trade off when compared to sump full of gas . Very obvious when flames were coming out of exhaust !!!! and it stung my eyes from gas fumes.Oil also smelled of gas and 3/4 inch over full.At a guess it only took 2-4 days to develop from a slow walker to rocket powered one complete with after burners HA HA HA :blob2: :blob2: :laugh:
    thanks tomo
     
  2. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,022

    I have never seen one do this but I did hear of one that wasn't caught in time and blew the engine up....Hmmm A little costly :cry:
     
  3. tomo

    tomo LawnSite Senior Member
    Posts: 660

    hello, pressurize [blow with mouth ] on inlet side of pump,while holding finger over outlet .Do this as u would expect still assembled to valve cover.I found a leak that i could hear coming from the inside of the v/cover. Removed diaphram from valve cover ,no tears splits etc but mine was obvious. The plunger attachment to diaphram was very very loose. Second give away was inside of the v/cover it was drying out evaporating to the point some areas were dry .[similar after u have washed parts in evaporating solvent].

    Good talking to ya R.R.
    thanks tomo:waving:
     
  4. pugs

    pugs LawnSite Gold Member
    Posts: 3,022

    I think I have seen 2-3 of these in the past few years. We put some CH20's on some trailers for a guy. At least one of those had this problem. And another customer came in with that same problem on something else.

    However none of them have been disassembled though. All the parts have been there when I have taken the valve cover off and replaced it with a new one...
     

Share This Page