Konler/grasshopper

Discussion in 'Mechanic and Repair' started by tbitt1, Jul 31, 2005.

  1. tbitt1

    tbitt1 LawnSite Member
    Posts: 8

    I need help.

    I have a 20 hp Kohler CH 20. It runs fine until it looses RPMs. I could pull out the choke and it would catch again, and off I'd go. (not now) Replaced the fuel lines, filters, carburetor, and fuel pump. Seems to run fine with out a load. Governor looks like it working fine.

    Tom
     
  2. Lawn Masters

    Lawn Masters LawnSite Senior Member
    Posts: 850

    does it lose speed under load instantly? or does it work fine for awhile, then suddenly drop off?
     
  3. tbitt1

    tbitt1 LawnSite Member
    Posts: 8

    It happens Randomly, get more constant now.
     
  4. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,023

    Have you checked your gas cap vent ?
     
  5. tbitt1

    tbitt1 LawnSite Member
    Posts: 8

    New gas tanks and caps. But I will run it till it does it again, and loosen the cap.

    Thanks
    Tom
     
  6. tbitt1

    tbitt1 LawnSite Member
    Posts: 8

    Had gas cap so loose gas was spilling out. Changed the plugs too, better, but still happened. One plug was wet the other black. The engine smoked for the first few minutes, then cleared up. Ran great for a five minutes, lost power, pulled out the choke, it sputtered a few times, sped up, push in the choke, and every thing was fine again. Do you know what the compression should be?
     
  7. tbitt1

    tbitt1 LawnSite Member
    Posts: 8

    130 PSI on both cylinders and it held. I'm sure that's good, but I don't have a lot of experience with 4 cycle engines. Both spark plugs are burning white with a touch of rust color.

    Thanks
    Tom
     
  8. wushaw

    wushaw LawnSite Member
    Posts: 61

    Your needing to choke it to get it to running after it starts loosing rpms, It maybe a air leak in the intake or float level is too low or needle is sticking.
    Is is starving for fuel it what it boils down to.
     
  9. tbitt1

    tbitt1 LawnSite Member
    Posts: 8

    Discovered I have no spark on one side. Magneto?
     
  10. olderthandirt

    olderthandirt LawnSite Platinum Member
    from here
    Posts: 4,900

    check the coil
     

Share This Page