1. Missed the live Ask the Expert event?
    Not to worry. Check out the archived thread of the Q&A with Ken Hutcheson, President of U.S. Lawns, and the LawnSite community in the Franchising forum .

    Dismiss Notice

Kubota ZD28 Issue

Discussion in 'Mechanic and Repair' started by sricks, Oct 9, 2006.

  1. sricks

    sricks LawnSite Member
    from Texas
    Posts: 16

    I have a ZD28 with the 72" pro deck that has a little over 60 hrs. The left drive motor always seemed a little weaker than the right, but I attributed it to the inaccurate adjustment of the control arm. Over the weekend, the left drive motor began losing power and the more forward you pushed the control arm, the worse it would get.

    The loss of power is accompanied by a loud noise which sounds like hydralic fluid escaping past a valve with alot of turbulance. Pull the control arm back some and you regain some power and the noise stops but you do not regain enough power to keep up with the right motor if you have any speed. If you are on a hill and need to turn up the hill using the left motor, it flat will not move the machine without help from the right motor.

    Oil is full, filter changed about 10 hrs ago. Any ideas before I have to load the mower up and take it to the dealer??

  2. tomo

    tomo LawnSite Senior Member
    Posts: 660

    hello , sounds like waranty issue ,unfortunately cannot give u advice but my impressiion was all the recent tranny issues were solved with upgrades and/or redesigned tranny .I was looking into purchasing a 28/60 but elected not to due to trans issues. Tranny problems r well documented if u do a search.Good luck great mower if there were no trans problems.
  3. Daner

    Daner LawnSite Bronze Member
    Posts: 1,308

    Take It back to the dealer...They do have there trany problems...I have been one of the lucky ones with no tranny problems. Mine Is an 2004 model.
  4. Grass Cake

    Grass Cake LawnSite Senior Member
    from Zone C
    Posts: 299

    My ZD had the exact symptoms....much worse when you were on a slope. twice they tried to tell me they had it fixed.....the second time i never left the dealer.....took it straight to a nearby hill and felt no difference.

    They finally replaced the hydro pump......runs like silk now.
    It's also a known problem with the kubota setup.

Share This Page