Kubota ZG help!

Discussion in 'Mechanic and Repair' started by parrithead, Aug 19, 2012.

  1. parrithead

    parrithead LawnSite Member
    Posts: 5

    I have a ZG222. It is about 3 1/2 years old with around 120 hours on the meter. Problem is that it seems like only the left control arm is working. The right arm will control, but i would guess it to be at maybe 10% of what it used to be. I know that this unit only uses 1 hydro, but do not truly understand how it works. I checked all of the fluids and they are fine. I had changed the hydro fluid at 50 hrs as a precaution. The unit is greased very 4-5 hours. I have not had any issues at all with the mower. Has anyone else has a similar problem? Or maybe can shed some light on my issue or a least point me in the right direction.

    Thanks
     
  2. TNGrassCutter

    TNGrassCutter LawnSite Bronze Member
    Posts: 1,321

    Maybe the linkage has come loose or something. What kind of warranty do you have, it should be covered if you are still in warranty.
    Posted via Mobile Device
     
  3. TriCityLawnCareLLC

    TriCityLawnCareLLC LawnSite Bronze Member
    from Ohio
    Posts: 1,024

    I have a zg222 bought new in 2009 now has 500+ hours. It's working great! Is either if the sticks more limp/looser than the other?
    Posted via Mobile Device
     
  4. parrithead

    parrithead LawnSite Member
    Posts: 5

    Not sure about the warranty? Its almost 4 years old. The sticks are tight, both about the same. Just seems that the right one doesnt control?
     
  5. dutch1

    dutch1 LawnSite Silver Member
    from Jayhawk
    Posts: 2,231

    Is the control arm on the transmission retained by the means of a roll pin? If so, you may have a broken roll pin.

    Just a shot in the dark from looking at one of the ZG222's on Kubota's website.
     

Share This Page