1. Missed the live Ask the Expert event?
    Not to worry. Check out the archived thread of the Q&A with Ken Hutcheson, President of U.S. Lawns, and the LawnSite community in the Franchising forum .

    Dismiss Notice

Leaf vac run issue

Discussion in 'Mechanic and Repair' started by QuadRacer041, Oct 25, 2012.

  1. QuadRacer041

    QuadRacer041 LawnSite Senior Member
    Posts: 365

    I have a Fradan leaf vac with a 18hp brigs engine. Just got it ready this past weekend and have noticed that it has a stumble when running. When you first start it up i turn off the choke and it will want to stall. I'll have to chycle the choke on and off a few times till it stays running. then once running it has a stumble no matter what throttle position i am in. I have replaced the air and fuel filters and sprayed carb cleaner into the carb with the air filter removed. It still does the same thing, I have looked at the plugs and they look normal, not covered in fuel.
    Any ideas?
  2. dutch1

    dutch1 LawnSite Silver Member
    from Jayhawk
    Posts: 2,231

    It would appear that you have a main jet blockage. You will likely have to clean the carb. I'm assuming the engine is a briggs horizontal vanguard. Do you have engine numbers?

    I'm not familiar with the unit you're working on so don't know how accessible the carb is. I've cleaned up several carbs on Billy Goat truck loaders and was able to do so without removing the carb.

    You may want to do a search of this site--for some reason I recall that the issue has been covered before.
  3. QuadRacer041

    QuadRacer041 LawnSite Senior Member
    Posts: 365

    The owners manual says vangaurd 350000/380000, that help?

Share This Page