1. Missed the live Ask the Expert event?
    Not to worry. Check out the archived thread of the Q&A with Ken Hutcheson, President of U.S. Lawns, and the LawnSite community in the Franchising forum .

    Dismiss Notice

Leaf vac troubles! HELP!

Discussion in 'Mechanic and Repair' started by srl28, Oct 31, 2007.

  1. srl28

    srl28 LawnSite Bronze Member
    Posts: 1,176

    I have a 2004??? ODB xtreme leaf vac. Has the 27 hp Kawi 750D engine on it. Was running fine, 16 hours on it decides to turn off during a cleanup. Wont start back up. Sounds like its starving for gas, just wont turn over. Fuel pump is fine, starting fluid doesnt help at all.....I think it is an electrical issue...Any ideas or tips or help at all????? Please! need this back in action asap....Thanks
  2. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,023

    First, I'm not familiar with this brand vac but on the engine there will be two white wires coming out of the flywheel cover to a harness plug connector. These two wires go to the coils for shutting the engine down, Disconnect these two wires and try starting it again.

    If it does start there is a problem with the ignition switch/wire harness or any other safety device switches that may be on this unit.
  3. srl28

    srl28 LawnSite Bronze Member
    Posts: 1,176

    Wow very helpful info thank you but I really cant find those white wires. Would they be any other color or where exactly would they be? It is a horizontal mount shaft if that helps. The leaf vac is made by odb...there site is www.theodbco.com I believe I have the xtreme vac tow behind with 27 hp kawisaki 750d engine.
  4. srl28

    srl28 LawnSite Bronze Member
    Posts: 1,176

Share This Page