Lesco Z2

Discussion in 'Lawn Mowing' started by davidw221, Aug 4, 2004.

  1. davidw221

    davidw221 LawnSite Member
    Posts: 10

    I have a Lesco Z2 54" mower, and when I mow I get a mohawk from under the deck and have to repeat mowing, talked to the Lesco dealer, and was told the deck was crooked, well I measured the back of the deck to the rear drive wheels, and its the same distance on each side, so I don't think thats the problem, any one else have this problem with Lesco Z2 mowers, and how is the problem fixed? this is costing me a lot of time and effort to get a lawn mowed. Like the mower, but the lip service i'm getting from Lesco isn't so good!
  2. sawdust

    sawdust LawnSite Member
    Posts: 39

    I have a Z2 54" and cuts fine. Make sure you have 19" blades. Which lesco store are you going through? Talk to Dave floats between north and south store. He should be able to help.
  3. wriken

    wriken LawnSite Silver Member
    Posts: 2,154

    I don't have a 54", but do run 2 60"s and a 72" and a 36"w/b, they all cut great.
  4. tiedeman

    tiedeman LawnSite Fanatic
    from earth
    Posts: 8,745

    what type of grass is it, thick, thin, etc? Also are the belts loose, blades not the right size? The height spacers or adjusters are fine on the deck and on the blades?
  5. johnmrchase

    johnmrchase LawnSite Member
    Posts: 1

    Had the same problem this past summer, after checking all spacers etc, found loose spindle mounting bolt on one spindle, not enough to throw a bely or notice vibrations, tightened them up and good to go.
  6. FinalCut05

    FinalCut05 LawnSite Member
    Posts: 79

    Talk to Envy about this one, he has helped me alot in the past with my Tank. Seems like he knows everything about this mower. I have the Cub Cadet version, where does the mohawk occur at ?

Share This Page