litlle wonder blows its top!

Discussion in 'Lawn Mowing' started by MATTHEW, Nov 5, 2001.


    MATTHEW LawnSite Senior Member
    from NE OHIO
    Posts: 665

    Been using the little wonder for 2 weeks now. Today it made a big "POP" and died. I found some metal sticking out of a gap where the head gasket goes, and if I pull the recoil, I feel air blowing out. Now, I checked the oil and it was dry in there. It took 3/4 of a quart to fill it up. Do you think It is toast?
  2. Eric ELM

    Eric ELM Husband, Father, Friend, Angel
    Posts: 4,831

    It doesn't sound good at all. :(
  3. Dochere

    Dochere LawnSite Member
    Posts: 137

    ...metal sticking out of a gap where the head gasket goes...

    Take it back and hope!
  4. John DiMartino

    John DiMartino LawnSite Silver Member
    Posts: 2,555

    Mathew-is this the first time you checked the oil?It sounds like it popped a head gasket,could be related to the fact that it was overheating from lack of oil?My 8hp is 2 yrs old now,I have used opti-1 in it since new,it doesnt us any oil at all,Ive got about 75 hrs on it now,no trouble with it what so ever.BTW that enigne only holds a little more than 3/4 of a quart of oil.New equipment uses oil until broken in,from my experiences.
  5. MuskTurfKing

    MuskTurfKing LawnSite Senior Member
    Posts: 338

    Sounds like it's warrenty to the rescue, hopefully.

  6. David Gretzmier

    David Gretzmier LawnSite Gold Member
    Posts: 3,645

    the same thing happened to me! I checked the oil every other use, and it blew out the side! oil went everywhere! dealer would not honor warranty on briggs, AND he talked me out of the Honda when I bought it originally. buddy of mine bought it, repalced the 8 I/C with a new10 horse I/C briggs, 20 hours later now it leaks oil ! I had a 5 horse used billy goat blower for a while, no problems but hard starting. wonder if anyone else has experienced the Little Wonder/Briggs problem...
  7. John DiMartino

    John DiMartino LawnSite Silver Member
    Posts: 2,555

    I guess me and my cousin have been lucky,neither of us has had any trouble with our 8 hp briggs.I wanted the Honda,but 300 dollars difference,and I really do not use it enough to justify the cost.Like i said,I have been running OPTI-4 in it since new,this doubles my manufacturers warranty,so Im still in warranty,from Opti that is.
  8. CSRA Landscaping

    CSRA Landscaping LawnSite Bronze Member
    Posts: 1,232

    My 8HP LW likes to use a little oil after it's run for a while. Smoke starts billowing out all of a sudden. If I idle it down for a minute and then take it back up again, it's ok.
  9. K9LWT

    K9LWT LawnSite Member
    Posts: 35

    I just brought home a LW 10hp briggs today. Needless to say, I will be checking the oil before each use. Mine came with a 5yr warranty-I think it even includes the briggs.
  10. Turfdude

    Turfdude LawnSite Bronze Member
    Posts: 1,900

    Very IMPORTANT....

    All push blowers w/ briggs & strattonengines need to do the following:

    1. When purchasing have dealer inal an oil alert sensor (cost approx $10.00 This will make the warranty go back to the manufacturer because these engines burn a lot of oil!

    2. Check oillevel at start of day and if being used for hours on end at lunch break too. The engines e excellent, but keep an eye on the oil level.;)

    Schools out for today.

Share This Page