Mazer HP died and now has NOTHING

Discussion in 'Mechanic and Repair' started by ProStreetCamaro, Apr 25, 2010.

  1. ProStreetCamaro

    ProStreetCamaro LawnSite Platinum Member
    Posts: 4,103

    Going down the street to start a lawn and poof it died. When i hit the key I had absolutely nothing not even a click from the starter. I checked the battery and it is good. I am not good with electrical stuff so I dont even know where to start with this. This old mower is our back up mower and I really need to get this guy going.

    EDIT: Title should read Lazer HP
     
  2. GlynnC

    GlynnC LawnSite Senior Member
    Posts: 774

    My 1st guess would be a fuse--somewhere. Second guess would be a safety switch.
     
  3. ProStreetCamaro

    ProStreetCamaro LawnSite Platinum Member
    Posts: 4,103

    Well I was wrong. The battery tested ok with a volt meter but apparently a cell went bad. Swapped in the battery out of our 160Z and it fired right up. Off to advanceauto I shall go!
     
  4. Mowingman

    Mowingman LawnSite Platinum Member
    from Texas
    Posts: 4,647

    What exactly is a "Mazer"?
     
  5. ProStreetCamaro

    ProStreetCamaro LawnSite Platinum Member
    Posts: 4,103


    :laugh: Lazer



    Just put the new battery in and old faithful fired right up. YaY 2500 hour kohler! :drinkup:
     
  6. Mowingman

    Mowingman LawnSite Platinum Member
    from Texas
    Posts: 4,647

    That is what I thought. Pretty funny though. Glad you got it going again.
     

Share This Page