1. Missed the live Ask the Expert event?
    Not to worry. Check out the archived thread of the Q&A with Ken Hutcheson, President of U.S. Lawns, and the LawnSite community in the Franchising forum .

    Dismiss Notice

Meg-Mo on JD757 with 60" deck

Discussion in 'Lawn Mowing' started by amdx64, Aug 3, 2008.

  1. amdx64

    amdx64 LawnSite Member
    from Vt
    Posts: 55

    Has anyone with a JD 757 60" deck tried the meg-mo system on there machine? did you have any trouble with the cut quality?
  2. gene gls

    gene gls LawnSite Gold Member
    Posts: 3,213

    I have a 27 HP engin and it struggled to run the blades. The engin is over loaded all the time.
  3. amdx64

    amdx64 LawnSite Member
    from Vt
    Posts: 55

    :confused: i have a 25 hp and it doesnt have trouble running the blades. the problem i have is the blades leave two strips of grass then i have to double cut.:realmad: i never had to double cut with the high lift blades
  4. MowHouston

    MowHouston LawnSite Bronze Member
    Posts: 1,012

  5. amdx64

    amdx64 LawnSite Member
    from Vt
    Posts: 55

    i wanted to return them but when i call the phone #was no longer in service so i emailed and never got a response now the 30 money back is past and i am out $250:wall:realmad::wall:realmad: i really wanted them to work well but very disappointed. :cry:
  6. deerex

    deerex LawnSite Member
    Posts: 96

    Without question the worst grass cutting blades I have ever used on my 757.

Share This Page