Meg-mo's on a Ferris

Discussion in 'Lawn Mowing' started by Travis Followell, Jul 31, 2005.

  1. Travis Followell

    Travis Followell LawnSite Silver Member
    from KY
    Posts: 2,207

    Just wondering if anyone has had any experience running meg mo blades on a Ferris ztr?
     
  2. cpipke

    cpipke LawnSite Member
    from Ohio
    Posts: 84

    Hello, yes used them for the first time Friday and they worked great, I have (3) 2005, IS 3000Z and I will be adding Meg-Mo's on the other 2 soon.
     
  3. Travis Followell

    Travis Followell LawnSite Silver Member
    from KY
    Posts: 2,207

    We also have a 2005 IS 3000. Did the meg mo's seem to reduce grass build-up under the deck? Thats the only thing I don't like about the machine. It cuts great until it gets some grass stuck under there then the quality seems to go down and it does this in completely dry grass.
     
  4. cpipke

    cpipke LawnSite Member
    from Ohio
    Posts: 84

    I used them on 6 lawns and 4 of them had a heavy morning dew and I had no problems at all and on the late afternoon lawns no issues but I did get covered in fine grass clipping and I loved it. I have tried several of the Gator products and I have not been impressed. I would recommend them to anyone.
     
  5. Lake Claire Lawn Ranger

    Lake Claire Lawn Ranger LawnSite Member
    Posts: 242

    What about on a Hydrowalk 36?
    Looking at $130, that would buy about 5 sets of blades.
     
  6. John Gamba

    John Gamba LawnSite Fanatic
    from ct
    Posts: 10,812

    Wait till the leaves fall :D
     
  7. cpipke

    cpipke LawnSite Member
    from Ohio
    Posts: 84

    I have 1 2005 Ferris 36" hydro but I have not purchased Meg-Mo's for that unit yet unfortunately I only have 2 hours on that unit and I will probably sell it if I can, all my clients have larger properties. Let me know if anyone is using them on a 36" walk behind.

    Thanks Cpipke
     

Share This Page