Mini Z won't start

Discussion in 'Hustler Turf Equip (Archived)' started by gtclark, Jul 31, 2013.

  1. gtclark

    gtclark LawnSite Member
    Posts: 2

    Ok, my 5 year old Huslter Mini Z decided that it didn't want to start today. Since it had the original battery still in it I thought that it might be the culprit. I changed the battery out and it still won't even attempt to turn over.

    I'm not sure if it's the starter or what. It has the Kawasaki 19hp engine and the only problem that I have had was a bad PTO/Blade switch that I had to replace.

    I have tried everything I know to get it started. The park switches appear to be working correctly along with the seat sensor. When I have the key in the start position the engine will not start but when I engage the PTO/Blade switch there is a loud click indicating that the PTO/Blade has engaged. It also clicks when I disengage the PTO/Blade switch.

    Has my starter gone south?
     
  2. hustlermidwest

    hustlermidwest LawnSite Senior Member
    Posts: 636

    Do you have juice to the starter. The noise you hear tells me you have juice to the starter.

    Brian O
     
  3. gtclark

    gtclark LawnSite Member
    Posts: 2

    Put in a new battery today but that wasn't it. I also:

    bypassed the starter solenoid - didn't work
    moved around the relays under the control panel - didn't work
    bypassed the seat switch - didn't work
    bypassed the parking brake (handles) switches - didn't work

    Is there anything else I can try.

    I can hear a click from under the control panel (relay switch or ignition switch) when I turn the key, but nothing else.
     
  4. Dorian Gilbert

    Dorian Gilbert LawnSite Member
    Posts: 26

    Good day, use a volt meter and follow the points to see where you are loosing the voltage.
     

Share This Page