Mower blades won't engage on Super Z

Discussion in 'Hustler Turf Equip (Archived)' started by Skyco Mowing, May 27, 2005.

  1. Skyco Mowing

    Skyco Mowing LawnSite Member
    Posts: 2

    The last few weeks when I would engage the blades, after I had been mowing a while it would not engage. I would cycle the swith and it would work great for a few days to a week with no problem engaging. Today I started mowing and it worked great for about 20 min. Then I was mowing on flat ground and it started engaging and disengaging while mowing. I stopped and put the brakes on and pushed the switch in and then I pulled it out and it started engaging in and out the weird part was it kept going with the switch in the off position. after about 30 min. it finally stopped that was the last time it engaged. Do any of you or PJ please help with your best guess think that it is the switch or the clutch. It is a ogura clutch. My mower is an 93 Super Z 60 in. with 68 hours on it. This mower is used only here at the house with 3 acre lawn. Thanks
     
  2. mowerconsultant

    mowerconsultant LawnSite Fanatic
    Male, from Syracuse, NY
    Posts: 9,761

    You can adjust the clutch per your owners manual and see if and or how long that helps.
    Ultimately you will need to put the newer Warner clutch on the unit.
    I don't believe it is a switch, it is a matter of adjusting the air gap.

    Pj
     
  3. Skyco Mowing

    Skyco Mowing LawnSite Member
    Posts: 2

    Thanks Pj, I picked up a new clutch kit and have it for when the other filally dies. I adjusted the air gap and it was still in adjustment range. The switch ended up being bad. Some how it had gotten moisture in it and was rusty inside when I opened it. Put a new switch in and it works good as new. This Hustler is still the best mower and ztr I have ever owned. I will never own anything but a Hustler product again. Thanks for yor help.
     
  4. mowerconsultant

    mowerconsultant LawnSite Fanatic
    Male, from Syracuse, NY
    Posts: 9,761

    Good, as long as it is working for you now.
    An you also have the upgrade kit to install if it fails.
    Glad to help anyone out here on LS, if anyone needs anything, post it here or e-mail me.

    Pj
     

Share This Page