Mower won't stay running

Discussion in 'Mechanic and Repair' started by Travis1010, Jul 8, 2013.

  1. Travis1010

    Travis1010 LawnSite Member
    Posts: 102

    I have a grasshopper with kohler ch 20s and won't stay running unless you hold the key in start position with starter going it seems like as soon as you let go it loses spark? I'm not sure what's wrong
    Posted via Mobile Device
     
  2. Travis1010

    Travis1010 LawnSite Member
    Posts: 102

    im not sure how the ignition system works but is there a way to test the spark while key is on the on position. I know this is the problem but dont know how to fix it.
     
  3. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,024

    Sounds like you have a safety switch issue, Possibly the seat or parking brake......
     
  4. Landrus2

    Landrus2 LawnSite Platinum Member
    Posts: 4,812

  5. Travis1010

    Travis1010 LawnSite Member
    Posts: 102

    im pretty sure its already unplugged but i will try. I dont see why it will run though if you hold the key on but as soon as u let go it dies. Ive checked every fuse
     
  6. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,024

  7. Travis1010

    Travis1010 LawnSite Member
    Posts: 102

    i wont be able to get other numbers up yet cause at my shop down the road. I checked the seat and still nothing. I noticed the brake and oil light dont come on when i turn the key. Im thinking something got shorted but I have checked all fuses unless theres one im missing. Im really confused at what this could be
     
  8. Travis1010

    Travis1010 LawnSite Member
    Posts: 102

    It would be a switch though because that means it wouldnt even start at all? Im thinking the ignition got messed up but im no electrician.
     
  9. Travis1010

    Travis1010 LawnSite Member
    Posts: 102

    Does any one know...I need it by next Wednesday!!
     
  10. herler

    herler LawnSite Fanatic
    Posts: 5,144

    Man I hope you're not in for it, if it makes you feel any better my Z broke down and it took weeks to get it going... Tell you what I did, started to call around to find places that rent them, they're not cheap so clever scheduling is recommended, also when you do find one remember you'll have to sharpen the blades first.
    No, I'm serious, a rented Ztr will most likely have seriously dull blades.

    Rent ran me an average of $175 to $225 a day.
    If you get to this point it's not about profit anymore, it's about getting the work done so you don't fall too far behind.
    In between you work on the mower.

    Now you can try, before going that route...
    The first thing to do is check the FUSE!

    Then I would pull the ignition switch CAREFULLY and see if all the wires are still connected.
    Obviously it would be peachy if one wire had simply become disconnected and you can just hook it right back up, bingo!

    If that's not the case you'll want to study said switch because they make two or three different kinds, and make a diagram of which wire goes where (usually there are letters marking the poles, can't recall exactly but like D and W and such, this will all have to be written down before disconnecting ANY wires).

    Now disconnect all wires, grab the switch and get on the Internet, start looking.
    Napa carries some, Advance others, Home Depot and Lowe's as well.
    Good luck matching it up.
     
    Last edited: Jul 11, 2013

Share This Page