Mustang 8003 ex pump probs

Discussion in 'Heavy Equipment & Pavement' started by Nel-Martin, Jan 7, 2010.

  1. Nel-Martin

    Nel-Martin LawnSite Member
    from ON
    Posts: 112

    we got a 01 mustang with pump probs , what happens is it with work good for 2-3 min then the GPM an pressure goes down . gpm goes down to 4 gpm an pressure to 2000 psi , can anyone figure it out ?
    :dizzy:
     
  2. Nel-Martin

    Nel-Martin LawnSite Member
    from ON
    Posts: 112

    sorry ... when it is working it works good for 2-3 min
     
  3. curtisfarmer

    curtisfarmer LawnSite Senior Member
    Posts: 511

  4. curtisfarmer

    curtisfarmer LawnSite Senior Member
    Posts: 511

    Somewhere there is a leak, blown seal, or a bad impeller, or clogged filter...hopefully.
     
  5. bobcat_ron

    bobcat_ron LawnSite Fanatic
    Posts: 10,082

    It's a Mustang, they are crap, I know, I broke one that my Dad owned, not once, not twice, not thrice, but 4 times in 2 years.
     
  6. Nel-Martin

    Nel-Martin LawnSite Member
    from ON
    Posts: 112

    valve bank had the seals all changed , an not sure if a filter would clog in 1500 hrs or im sure there is no leak either
     
  7. curtisfarmer

    curtisfarmer LawnSite Senior Member
    Posts: 511

    Doesn't look good from here.;)
     
  8. Nel-Martin

    Nel-Martin LawnSite Member
    from ON
    Posts: 112

    nope it dont look good , had it at few diffrent dealers to figure out they couldnt do anythin an price on a new pump in outrageous
     
  9. curtisfarmer

    curtisfarmer LawnSite Senior Member
    Posts: 511

    How much for new pump?
     
  10. Nel-Martin

    Nel-Martin LawnSite Member
    from ON
    Posts: 112

    8500 is a new one , a year ago we could have got it for 5k
     

Share This Page