1. Missed the live Ask the Expert event?
    Not to worry. Check out the archived thread of the Q&A with Ken Hutcheson, President of U.S. Lawns, and the LawnSite community on the Franchising Forum.

    Dismiss Notice

My current lawncare setup

Discussion in 'Original Pictures Forum' started by peeklandscaping, Jul 4, 2013.

  1. peeklandscaping

    peeklandscaping LawnSite Senior Member
    from CT
    Posts: 306

    Here are some photos of my equipment. Been in business just under a year. Currently have a 2000 Toyota Tacoma with utebed, scag V-ride, 5x12 and 5x8 trailers, stihl kombi-system, shindawia hedge trimmer and weedwacker, fraden truckloader leaf vacuum, stihl chainsaw, and kobalt hand tools. Will get some better pictures soon.
    Will hopefully be getting a F350 in a couple of months, for fall cleanups and snow-plowing.
    P1090103.jpg

    P1080831.jpg

    P1080861.jpg

    P1080964.jpg

    P1090006.jpg

    P1090103.jpg

    P1080831.jpg

    P1080861.jpg

    P1080964.jpg

    P1090006.jpg
     
  2. Landrus2

    Landrus2 LawnSite Platinum Member
    Posts: 4,811

    When I started in 1975 my first year I had no toys like that congrats :waving:
     
  3. Jaybrown

    Jaybrown LawnSite Bronze Member
    Posts: 1,160

    My John Deere 925 a doesn't spread the clippings out properly. It shoots it in spurts. I have to double cut a lot. If I cut with my stander the clippings are finer and more spread out. You can even notice them. On the same lawn that I have to double cut with the jd. What gives
     
  4. peeklandscaping

    peeklandscaping LawnSite Senior Member
    from CT
    Posts: 306

    Jaybrown, I had the same issue with the turf tracer I used to have. I figured wet grass plus mulch blades were the problem. The V-ride will go through almost anything without a problem.
     

Share This Page