My Exmark Lazer Z Liquid Cooled just cuts off

Discussion in 'Lawn Mowing' started by FHB, Apr 3, 2010.

  1. FHB

    FHB LawnSite Member
    Posts: 4

    My exmark lazer z just cuts off. It is sitting at the end of my driveway now. it is sitting on a small slope, just wondering if the tilt switch could be bad and if anyones had this issue before. the last time it cut off, i made a real sharp turn real fast and it died but shortly after restarted. also, is there anyway to move that thing when its off, if it is the tilt switch, i need to get it off the slope so I can refire it. thanks for all the insights.
     
  2. specialtylc

    specialtylc LawnSite Bronze Member
    Posts: 1,656

    Check all safety switches.
     
  3. unkownfl

    unkownfl LawnSite Gold Member
    Posts: 3,838

    Open the release valves on the hydro pumps just a half turn and then you can push/tow it out. EFI or Carb?
     
  4. MJB

    MJB LawnSite Silver Member
    from Wa
    Posts: 2,869

    Sounds like a possible fuel issue too. Does your have a switch between tanks? Check that out too.
     
  5. Think Green

    Think Green LawnSite Silver Member
    Posts: 2,746

    FHB,
    If I can remember correctly, the carb has a anti-backfire switch just below the bowl. If this this becomes dislodged, the fuel cannot get to the bowl. Another stupid feature with real potential, that satisfied the law makers. It was designed to quiet these mowers with big engines from backfiring the excess fuel vapors that escape into the muffler.
     

Share This Page