Nedd help with 3.5 HP Briggs

Discussion in 'Mechanic and Repair' started by fordmstng66, Sep 1, 2009.

  1. fordmstng66

    fordmstng66 LawnSite Member
    from Ohio
    Posts: 51

    I have an older Kee commercial edger with a Briggs 3.5HP motor. I was using it, and it was running fine, then just shut of, and now it will not start. I put new plug in, removed carb, and cleaned it, and still would not start. I then purchased new gaskets, and diaphragm, put it back together, drained old gas put new gas in, and still same problem. It has spark, is there anything i may be missing. The edger is about 10 years old, but does not really see a lot of use, it has been used for my moms yard, and with in the last 4 years my yard. Any help would be great

    thanks in advance
     
  2. FIXDISS

    FIXDISS LawnSite Senior Member
    Posts: 445

    The flwheel wheel key comes to mind first of all. If you spray a little carb cleaner into the carb and pull the rope does it pop or backfire ? Have also seen the keeper come loose on one of the valve stems. Check compression before you pull the starter housing off. Since this engine is that old I figure it is not an OHC engine. Maybe these suggestions will help you narrow it down. If neither one are your problem....After all,this is just my "half-fast" opinion. good luck.
     
  3. fordmstng66

    fordmstng66 LawnSite Member
    from Ohio
    Posts: 51

    fixDiss

    I have not sprayed any carb cleaner in, but have tried starting fluid (hate using it) and even sprayed a mist of gas in it, it doesn't seem to backfire, but it really seems like it is not sparking, but i know it has spark. It does not backfire, just throws whatever i spray in right back out, thanks i will try the cleaner, and also check compression
     

Share This Page