Need help soon!!!

Discussion in 'Hustler Turf Equip (Archived)' started by KirbysLawn, Nov 14, 2003.

  1. KirbysLawn

    KirbysLawn Millenium Member
    Posts: 3,486

    Today the left wheel started stopping, going forward or backward, just out of the blue instant brakes. Go back and forth, and it would stop. I parked it and noticed that the brake on the left side is not working at all.

    I have a ton of work tomorrow and Whitleys is closed on Monday so it will be Tuesday before they are able to look at it. Any ideas what may cause this?? All linkages look good, I am going to take the tire off tomorrow and have a look.
     
  2. mowerconsultant

    mowerconsultant LawnSite Fanatic
    Male, from Syracuse, NY
    Posts: 9,761

    Ray,
    Pull your brake drum, check the brake shoes, and the bolts that retain the backing plate to the wheel motor.
    We have seen a couple of brake shoe linings come unglued, and also have seen some bolts back of the backing plate.
    These were early build units, and we will take care of it under warranty.
    You have my # from my last e-mail to you, call me if you need any help.

    Pj
     
  3. KirbysLawn

    KirbysLawn Millenium Member
    Posts: 3,486

    Now see, that's what I call service! Took a whole 2 hours on a Friday night, what other mower company provides such service?

    PJ, I will try that in the morning.
     
  4. mowerconsultant

    mowerconsultant LawnSite Fanatic
    Male, from Syracuse, NY
    Posts: 9,761

    It would of been quicker if this cell modem would work right........I am at camp and the signal is not so good....call me if you have any questions...leave me a message if I dont answer, i will call you back ASAP.

    Pj
     

Share This Page